aboutsummaryrefslogtreecommitdiff
path: root/applications/inference_process/CMakeLists.txt
diff options
context:
space:
mode:
authorKristofer Jonsson <kristofer.jonsson@arm.com>2022-11-23 13:06:13 +0100
committerKristofer Jonsson <kristofer.jonsson@arm.com>2022-12-15 09:00:11 +0100
commit023b1eb953873ed5d813e4cbcb5b0bf63eb70568 (patch)
treeed3431605f9b0807a02bf3abcf6c44b340db3f77 /applications/inference_process/CMakeLists.txt
parent36426959f5dffdae920f03da6efe40d0fcc9754c (diff)
downloadethos-u-core-software-023b1eb953873ed5d813e4cbcb5b0bf63eb70568.tar.gz
Remove ethosu_core and ethosu_applications
Interface libraries ethosu_core and ethosu_applications are removed. Each application shall depend directly on the libraries they need. Change-Id: I4d37c6c50aa276beaa8e2681a63cea90977477ce
Diffstat (limited to 'applications/inference_process/CMakeLists.txt')
-rw-r--r--applications/inference_process/CMakeLists.txt20
1 files changed, 6 insertions, 14 deletions
diff --git a/applications/inference_process/CMakeLists.txt b/applications/inference_process/CMakeLists.txt
index 4142f11..a26a1e2 100644
--- a/applications/inference_process/CMakeLists.txt
+++ b/applications/inference_process/CMakeLists.txt
@@ -18,26 +18,18 @@
set(TR_PRINT_OUTPUT_BYTES "" CACHE STRING "Print output data.")
-add_library(inference_process STATIC)
+add_library(inference_process INTERFACE)
-target_include_directories(inference_process PUBLIC include)
+target_include_directories(inference_process INTERFACE include)
-target_link_libraries(inference_process PRIVATE tflu cmsis_core cmsis_device ethosu_crc)
-
-if (TARGET layer_by_layer_profiler)
- target_link_libraries(inference_process PRIVATE layer_by_layer_profiler)
-endif()
+target_link_libraries(inference_process INTERFACE tflu cmsis_core cmsis_device ethosu_crc)
if (TARGET arm_profiler)
- target_link_libraries(inference_process PRIVATE arm_profiler)
+ target_link_libraries(inference_process INTERFACE arm_profiler)
endif()
if (TARGET ethosu_log)
- target_link_libraries(inference_process PRIVATE ethosu_log)
+ target_link_libraries(inference_process INTERFACE ethosu_log)
endif()
-target_sources(inference_process PRIVATE src/inference_process.cpp)
-
-if (DEFINED INFERENCE_PROCESS_OPS_RESOLVER)
- target_compile_definitions(inference_process PRIVATE INFERENCE_PROCESS_OPS_RESOLVER=${INFERENCE_PROCESS_OPS_RESOLVER})
-endif() \ No newline at end of file
+target_sources(inference_process INTERFACE src/inference_process.cpp)