aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJens Elofsson <jens.elofsson@arm.com>2021-06-01 19:06:30 +0200
committerJens Elofsson <jens.elofsson@arm.com>2021-06-15 09:11:05 +0200
commita5e90fd528f425a32a1d26a3d794be0eb4e0b5f8 (patch)
tree0d8cea0253f4393005f438d46a0f6e3f1d55040d /CMakeLists.txt
parent53cc13d7f685bb7bb89dc33e6f6b1dd64c5ac2f4 (diff)
downloadethos-u-core-software-a5e90fd528f425a32a1d26a3d794be0eb4e0b5f8.tar.gz
Switch to the new tflite-micro repo.
Change-Id: I19b806e94207580ab548e8cd4ddada32debf0639
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7f5f1cb..cc0d39e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,7 +31,7 @@ set(CMSIS_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmsis" CACHE PATH "Path to CMSIS.")
set(CMSIS_VIEW_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmsis-view" CACHE PATH "Path to cmsis-view.")
set(CORE_DRIVER_PATH "${CMAKE_CURRENT_SOURCE_DIR}/core_driver" CACHE PATH "Path to core driver.")
set(LINUX_DRIVER_STACK_PATH "${CMAKE_CURRENT_SOURCE_DIR}/../linux_driver_stack" CACHE PATH "Path to Linux driver stack for Arm Ethos-U.")
-set(TENSORFLOW_PATH "${CMAKE_CURRENT_SOURCE_DIR}/tensorflow" CACHE PATH "Path to Tensorflow.")
+set(TENSORFLOW_PATH "${CMAKE_CURRENT_SOURCE_DIR}/tflite_micro" CACHE PATH "Path to Tensorflow Lite Micro.")
set(TFLU_PREBUILT_LIBRARY_PATH "" CACHE PATH "Path to a prebuilt TensorFlow Lite for Microcontrollers library.")
# Select accelerator for tensorflow
@@ -58,8 +58,8 @@ if (CORE_SOFTWARE_ACCELERATOR STREQUAL "NPU")
target_link_libraries(ethosu_core INTERFACE ethosu_core_driver)
endif()
-# Build Tensorflow library
-include(tensorflow.cmake)
+# Build Tensorflow Lite Micro library
+include(tflite_micro.cmake)
# Build RTOS
add_subdirectory(rtos)