aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJonas Ohlsson <jonas.ohlsson@arm.com>2021-05-05 10:48:03 +0200
committerJonas Ohlsson <jonas.ohlsson@arm.com>2021-05-05 10:48:03 +0200
commit7f3c1c92732b611a53968b14e70a2b116e43b980 (patch)
tree16c69c51237b578d43f903e836d27cc83414a771 /CMakeLists.txt
parente348f8f16feef3c473e9217b932468f828988aa3 (diff)
downloadethos-u-core-software-7f3c1c92732b611a53968b14e70a2b116e43b980.tar.gz
MLBEDSW-4228 Building on Windows21.05-rc221.05-rc1
Changes to facilitate building on Windows systems. Signed-off-by: Jonas Ohlsson <jonas.ohlsson@arm.com> Change-Id: I40ffad5fbbe0640a1026f6f8a95bd4a1ef0fb68b
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b7d3bea..e8d46ae 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,8 @@
# limitations under the License.
#
+# Note: On Windows systems CMake 3.20.0 might cause issues with errouneous dependency make files.
+# Issues solved with CMake 3.20.1.
cmake_minimum_required(VERSION 3.15.6)
project(core_software VERSION 0.0.1)
@@ -29,6 +31,7 @@ set(CMSIS_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmsis" CACHE PATH "Path to CMSIS.")
set(CORE_DRIVER_PATH "${CMAKE_CURRENT_SOURCE_DIR}/core_driver" CACHE PATH "Path to core driver.")
set(LINUX_DRIVER_STACK_PATH "${CMAKE_CURRENT_SOURCE_DIR}/../linux_driver_stack" CACHE PATH "Path to Linux driver stack for Arm Ethos-U.")
set(TENSORFLOW_PATH "${CMAKE_CURRENT_SOURCE_DIR}/tensorflow" CACHE PATH "Path to Tensorflow.")
+set(TFLU_PREBUILT_LIBRARY_PATH "" CACHE PATH "Path to a prebuilt TensorFlow Lite for Microcontrollers library.")
# Select accelerator for tensorflow
set(CORE_SOFTWARE_ACCELERATOR "NPU" CACHE STRING "Set NPU backend for Tensorflow Lite for microcontrollers")