aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBhavik Patel <bhavik.patel@arm.com>2020-07-29 12:28:18 +0200
committerBhavik Patel <bhavik.patel@arm.com>2020-10-27 16:58:48 +0100
commit68c1f1b463691fadbccef22e22d59f5e61546ca2 (patch)
tree1753440d0eada82577720109b92ada22ca3831f0 /CMakeLists.txt
parentd273d8e9c8513079f807b48af2e277f46469acf0 (diff)
downloadethos-u-core-software-68c1f1b463691fadbccef22e22d59f5e61546ca2.tar.gz
MLBEDSW-2593 Build FreeRTOS kernel as a part of ethosu_core target
The ethosu_core target now includes the FreeRTOS kernel if the CORE_SOFTWARE_RTOS is set to FreeRTOS. Currently supported builds are for cortex M3, M4, M7, M33, and M55. The FreeRTOSConfig.h file is generated as a part of the build. Change-Id: Ief6921fd0d9aa3849497ef0810d2714a12eb6773
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 99d829c..564d4d0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,6 +36,7 @@ set_property(CACHE CORE_SOFTWARE_ACCELERATOR PROPERTY STRINGS CPU CMSIS-NN NPU)
# Define build options
set(CORE_SOFTWARE_RTOS "None" CACHE STRING "Select RTOS to include. (None, MbedOS, FreeRTOS, Zephyr)")
+string(TOLOWER ${CORE_SOFTWARE_RTOS} CORE_SOFTWARE_RTOS_LOWER)
#
# Build
@@ -55,6 +56,10 @@ endif()
# Build Tensorflow library
include(tensorflow.cmake)
+# Build RTOS
+add_subdirectory(rtos)
+target_link_libraries(ethosu_core INTERFACE ethosu_core_rtos)
+
# Build applications
add_subdirectory(applications)