aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKristofer Jonsson <kristofer.jonsson@arm.com>2022-11-23 13:06:13 +0100
committerKristofer Jonsson <kristofer.jonsson@arm.com>2022-12-15 09:00:11 +0100
commit023b1eb953873ed5d813e4cbcb5b0bf63eb70568 (patch)
treeed3431605f9b0807a02bf3abcf6c44b340db3f77 /CMakeLists.txt
parent36426959f5dffdae920f03da6efe40d0fcc9754c (diff)
downloadethos-u-core-software-023b1eb953873ed5d813e4cbcb5b0bf63eb70568.tar.gz
Remove ethosu_core and ethosu_applications
Interface libraries ethosu_core and ethosu_applications are removed. Each application shall depend directly on the libraries they need. Change-Id: I4d37c6c50aa276beaa8e2681a63cea90977477ce
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 917c6d8..85470f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,13 +60,11 @@ add_library(ethosu_core INTERFACE)
# Build CMSIS
include(cmsis.cmake)
-target_link_libraries(ethosu_core INTERFACE cmsis_core cmsis_device)
# Build core driver
if (CORE_SOFTWARE_ACCELERATOR STREQUAL "NPU")
set(ETHOSU_PMU_INTERACTIVE OFF)
add_subdirectory(${CORE_DRIVER_PATH} core_driver)
- target_link_libraries(ethosu_core INTERFACE ethosu_core_driver)
endif()
# Build Tensorflow Lite Micro library
@@ -84,10 +82,6 @@ add_subdirectory(lib)
# Build applications
add_subdirectory(applications)
-
-# Merge libraries into static library
-target_link_libraries(ethosu_core INTERFACE tflu ethosu_applications)
-
message(STATUS "*******************************************************")
message(STATUS "PROJECT_NAME : ${PROJECT_NAME}")
message(STATUS "CORE_SOFTWARE_RTOS : ${CORE_SOFTWARE_RTOS}")