aboutsummaryrefslogtreecommitdiff
path: root/targets/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'targets/common/CMakeLists.txt')
-rw-r--r--targets/common/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/targets/common/CMakeLists.txt b/targets/common/CMakeLists.txt
index fa9b953..f3382f3 100644
--- a/targets/common/CMakeLists.txt
+++ b/targets/common/CMakeLists.txt
@@ -52,9 +52,7 @@ target_link_libraries(ethosu_target_link INTERFACE ethosu_target_common)
# Startup
add_library(ethosu_target_startup INTERFACE)
target_link_libraries(ethosu_target_startup INTERFACE ethosu_target_link)
-
-target_link_libraries(ethosu_target_startup INTERFACE $<TARGET_OBJECTS:cmsis_startup>)
-add_dependencies(ethosu_target_startup $<TARGET_OBJECTS:cmsis_startup>)
+target_link_libraries(ethosu_target_startup INTERFACE cmsis_system)
# Init
add_library(ethosu_target_init INTERFACE)