aboutsummaryrefslogtreecommitdiff
path: root/applications/message_handler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'applications/message_handler/CMakeLists.txt')
-rw-r--r--applications/message_handler/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/applications/message_handler/CMakeLists.txt b/applications/message_handler/CMakeLists.txt
index 6928c2d..5e95bdd 100644
--- a/applications/message_handler/CMakeLists.txt
+++ b/applications/message_handler/CMakeLists.txt
@@ -16,13 +16,13 @@
# limitations under the License.
#
-if (NOT TARGET freertos_kernel)
- message("Not building ethosu_message_dispatcher, required freertos not built.")
+if(NOT TARGET freertos_kernel)
+ message("Skipping message handler")
return()
endif()
# Split total tensor arena equally for each NPU
-if (TARGET ethosu_core_driver AND ETHOSU_TARGET_NPU_COUNT GREATER 0)
+if(TARGET ethosu_core_driver AND ETHOSU_TARGET_NPU_COUNT GREATER 0)
set(NUM_ARENAS ${ETHOSU_TARGET_NPU_COUNT})
else()
set(NUM_ARENAS 1)
@@ -41,10 +41,10 @@ set(MESSAGE_HANDLER_MODEL_3 "" CACHE STRING "Path to built in model 3")
ethosu_add_executable(message_handler
SOURCES
- main.cpp
+ main.cpp
LIBRARIES
- message_handler_lib
- freertos_kernel)
+ message_handler_lib
+ freertos_kernel)
target_include_directories(message_handler PRIVATE
indexed_networks