aboutsummaryrefslogtreecommitdiff
path: root/src/timelineDecoder/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/timelineDecoder/CMakeLists.txt')
-rw-r--r--src/timelineDecoder/CMakeLists.txt26
1 files changed, 10 insertions, 16 deletions
diff --git a/src/timelineDecoder/CMakeLists.txt b/src/timelineDecoder/CMakeLists.txt
index 695aa5cbe8..e7d5481eb5 100644
--- a/src/timelineDecoder/CMakeLists.txt
+++ b/src/timelineDecoder/CMakeLists.txt
@@ -1,37 +1,31 @@
#
-# Copyright © 2020 Arm Ltd. All rights reserved.
+# Copyright © 2020 Arm Ltd and Contributors. All rights reserved.
# SPDX-License-Identifier: MIT
#
if(BUILD_TIMELINE_DECODER)
- set(timelineDecoder_sources)
- list(APPEND timelineDecoder_sources
- ${PROJECT_SOURCE_DIR}/include/armnn/profiling/ITimelineDecoder.hpp
- TimelineCaptureCommandHandler.cpp
- TimelineCaptureCommandHandler.hpp
+ set(jsonTimelineDecoder_sources)
+ list(APPEND jsonTimelineDecoder_sources
JSONTimelineDecoder.cpp
- JSONTimelineDecoder.hpp
- TimelineDecoder.cpp
- TimelineDecoder.hpp
- TimelineDirectoryCaptureCommandHandler.cpp
- TimelineDirectoryCaptureCommandHandler.hpp)
+ JSONTimelineDecoder.hpp)
include_directories(${PROJECT_SOURCE_DIR}/src/profiling
${PROJECT_SOURCE_DIR}/profiling/common/include
+ ${PROJECT_SOURCE_DIR}/profiling/server/include/timelineDecoder
${PROJECT_SOURCE_DIR}/src/armnnUtils)
if(BUILD_UNIT_TESTS)
target_include_directories(UnitTests PRIVATE ${PROJECT_SOURCE_DIR}/src/timelineDecoder)
endif()
- add_library_ex(timelineDecoder SHARED ${timelineDecoder_sources})
+ add_library_ex(jsonTimelineDecoder SHARED ${jsonTimelineDecoder_sources})
- set_target_properties(timelineDecoder PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR})
- set_target_properties(timelineDecoder PROPERTIES VERSION ${GENERIC_LIB_VERSION} SOVERSION ${GENERIC_LIB_SOVERSION} )
+ set_target_properties(jsonTimelineDecoder PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR})
+ set_target_properties(jsonTimelineDecoder PROPERTIES VERSION ${GENERIC_LIB_VERSION} SOVERSION ${GENERIC_LIB_SOVERSION} )
- target_link_libraries(timelineDecoder armnn)
+ target_link_libraries(jsonTimelineDecoder armnn)
- install(TARGETS timelineDecoder
+ install(TARGETS jsonTimelineDecoder
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()