aboutsummaryrefslogtreecommitdiff
path: root/src/backends/cl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/backends/cl/CMakeLists.txt')
-rw-r--r--src/backends/cl/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/src/backends/cl/CMakeLists.txt b/src/backends/cl/CMakeLists.txt
index 60cdaa314d..78771a027e 100644
--- a/src/backends/cl/CMakeLists.txt
+++ b/src/backends/cl/CMakeLists.txt
@@ -8,15 +8,15 @@ if(ARMCOMPUTECL)
HINTS ${FLATC_DIR}
DOC "Path to 'flatc', the flatbuffers compiler")
if (NOT FLATC)
- message(SEND_ERROR "flatc not found. Specify the full path of the flatc executable with -DFLATC=<flatc path>")
+ message(WARNING "flatc not found. Specify the full path of the flatc executable with -DFLATC=<flatc path>")
+ else()
+ add_custom_command(
+ # Updates ClContextSchema_generated.h if changes are made.
+ OUTPUT ClContextSchema_generated.h DEPENDS ClContextSchema.fbs
+ COMMAND ${FLATC} -o ${CMAKE_CURRENT_BINARY_DIR} --cpp ${CMAKE_CURRENT_SOURCE_DIR}/ClContextSchema.fbs
+ )
endif()
- add_custom_command(
- # Generate an ClContextSchema_generated.h file if it doesn't exist, or update it when necessary otherwise
- OUTPUT ClContextSchema_generated.h DEPENDS ClContextSchema.fbs
- COMMAND ${FLATC} -o ${CMAKE_CURRENT_BINARY_DIR} --cpp ${CMAKE_CURRENT_SOURCE_DIR}/ClContextSchema.fbs
- )
-
list(APPEND armnnClBackend_sources
ClContextSchema_generated.h
ClBackend.cpp