aboutsummaryrefslogtreecommitdiff
path: root/profiling/server/src/basePipeServer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'profiling/server/src/basePipeServer/CMakeLists.txt')
-rw-r--r--profiling/server/src/basePipeServer/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/profiling/server/src/basePipeServer/CMakeLists.txt b/profiling/server/src/basePipeServer/CMakeLists.txt
new file mode 100644
index 0000000000..e535cf2e66
--- /dev/null
+++ b/profiling/server/src/basePipeServer/CMakeLists.txt
@@ -0,0 +1,25 @@
+#
+# Copyright © 2020 Arm Ltd. All rights reserved.
+# SPDX-License-Identifier: MIT
+#
+
+if(BUILD_BASE_PIPE_SERVER)
+ set(BasePipeServer_sources)
+ list(APPEND BasePipeServer_sources
+ BasePipeServer.cpp
+ BasePipeServer.hpp
+ ConnectionHandler.cpp
+ ConnectionHandler.hpp
+ )
+
+ include_directories(src/armnnUtils src/profiling)
+
+ add_library_ex(armnnBasePipeServer SHARED ${BasePipeServer_sources})
+ set_target_properties(armnnBasePipeServer PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR})
+ set_target_properties(armnnBasePipeServer PROPERTIES VERSION ${GENERIC_LIB_VERSION}
+ SOVERSION ${GENERIC_LIB_SOVERSION})
+
+ install(TARGETS armnnBasePipeServer
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+endif() \ No newline at end of file