aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b66ed5fe4c..867fb34071 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -451,7 +451,11 @@ list(APPEND armnn_sources
src/profiling/ConnectionAcknowledgedCommandHandler.hpp
src/profiling/CounterDirectory.cpp
src/profiling/CounterDirectory.hpp
+ src/profiling/DirectoryCaptureCommandHandler.cpp
+ src/profiling/DirectoryCaptureCommandHandler.hpp
src/profiling/EncodeVersion.hpp
+ src/profiling/FileOnlyProfilingConnection.cpp
+ src/profiling/FileOnlyProfilingConnection.hpp
src/profiling/Holder.cpp
src/profiling/Holder.hpp
src/profiling/IBufferManager.hpp
@@ -624,6 +628,7 @@ if(BUILD_UNIT_TESTS)
src/armnnUtils/test/ParserHelperTest.cpp
src/armnnUtils/test/TensorUtilsTest.cpp
src/profiling/test/BufferTests.cpp
+ src/profiling/test/FileOnlyProfilingDecoratorTests.cpp
src/profiling/test/ProfilingConnectionDumpToFileDecoratorTests.cpp
src/profiling/test/ProfilingGuidTest.cpp
src/profiling/test/ProfilingTests.cpp
@@ -925,12 +930,8 @@ if(BUILD_GATORD_MOCK)
tests/profiling/gatordmock/CommandFileParser.cpp
tests/profiling/gatordmock/CommandLineProcessor.hpp
tests/profiling/gatordmock/CommandLineProcessor.cpp
- tests/profiling/gatordmock/CounterDirectory.hpp
- tests/profiling/gatordmock/DirectoryCaptureCommandHandler.cpp
- tests/profiling/gatordmock/DirectoryCaptureCommandHandler.hpp
tests/profiling/gatordmock/GatordMockService.hpp
tests/profiling/gatordmock/GatordMockService.cpp
- tests/profiling/gatordmock/MockUtils.cpp
tests/profiling/gatordmock/PeriodicCounterCaptureCommandHandler.cpp
tests/profiling/gatordmock/PeriodicCounterCaptureCommandHandler.hpp
tests/profiling/gatordmock/PeriodicCounterSelectionResponseHandler.cpp