aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorFinn Williams <finn.williams@arm.com>2022-06-20 13:48:20 +0100
committerKeithARM <keith.davis@arm.com>2022-07-04 08:33:07 +0000
commit615e06f54a4c4139e81e289991ba4084aa2f69d3 (patch)
tree0a3bd2cc754cde1b3133a914597d607c52ce75ff /tests/CMakeLists.txt
parent504d5b7eb5dde6fa4fe0e41c8fd04e50aa212613 (diff)
downloadarmnn-615e06f54a4c4139e81e289991ba4084aa2f69d3.tar.gz
IVGCVSW-6650 Refactor ExecuteNetwork
* Remove InferenceModel * Add automatic IO type, shape and name configuration * Depreciate various redundant options * Add internal output comparison Signed-off-by: Finn Williams <finn.williams@arm.com> Change-Id: I2eca248bc91e1655a99ed94990efb8059f541fa9
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 4cb324f2c7..87a5b46024 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -139,6 +139,9 @@ if (BUILD_ARMNN_SERIALIZER
OR BUILD_ONNX_PARSER
OR BUILD_ARMNN_TFLITE_DELEGATE)
set(ExecuteNetwork_sources
+ ExecuteNetwork/IExecutor.hpp
+ ExecuteNetwork/ArmNNExecutor.cpp
+ ExecuteNetwork/ArmNNExecutor.hpp
ExecuteNetwork/ExecuteNetwork.cpp
ExecuteNetwork/ExecuteNetworkProgramOptions.cpp
ExecuteNetwork/ExecuteNetworkProgramOptions.hpp
@@ -147,6 +150,13 @@ if (BUILD_ARMNN_SERIALIZER
NetworkExecutionUtils/NetworkExecutionUtils.cpp
NetworkExecutionUtils/NetworkExecutionUtils.hpp)
+ if(BUILD_ARMNN_TFLITE_DELEGATE)
+ set(ExecuteNetwork_sources
+ ${ExecuteNetwork_sources}
+ ExecuteNetwork/TfliteExecutor.cpp
+ ExecuteNetwork/TfliteExecutor.hpp)
+ endif()
+
add_executable_ex(ExecuteNetwork ${ExecuteNetwork_sources})
target_include_directories(ExecuteNetwork PRIVATE ../src/armnn)
target_include_directories(ExecuteNetwork PRIVATE ../src/armnnUtils)