aboutsummaryrefslogtreecommitdiff
path: root/src/backends/cl/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Sloyan <matthew.sloyan@arm.com>2021-01-07 13:28:47 +0000
committerMatthew Sloyan <matthew.sloyan@arm.com>2021-01-11 17:03:54 +0000
commit80fbcd5f4d7b362360963af1df0121aa6b561576 (patch)
tree64c8d2588e55aad2813f6b07e40f87ac3b8e8ce1 /src/backends/cl/CMakeLists.txt
parenta20b3129aa1c450ccf867c7b63844e8391753730 (diff)
downloadarmnn-80fbcd5f4d7b362360963af1df0121aa6b561576.tar.gz
IVGCVSW-5483 'Implement Loading and Saving to File'
* Implemented Serialization and Deserialization of CLContext. * Fixed flatbuffers android-nn-driver dependency. !android-nn-driver:4772 Signed-off-by: Matthew Sloyan <matthew.sloyan@arm.com> Signed-off-by: Sadik Armagan <sadik.armagan@arm.com> Change-Id: If806f050535ffaa70922ba0f1ffe7bb10f902329
Diffstat (limited to 'src/backends/cl/CMakeLists.txt')
-rw-r--r--src/backends/cl/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/backends/cl/CMakeLists.txt b/src/backends/cl/CMakeLists.txt
index 4b5890af50..bfb99dde96 100644
--- a/src/backends/cl/CMakeLists.txt
+++ b/src/backends/cl/CMakeLists.txt
@@ -4,7 +4,23 @@
#
if(ARMCOMPUTECL)
+ find_program(FLATC flatc
+ HINTS ${FLATC_DIR}
+ DOC "Path to 'flatc', the flatbuffers compiler")
+ if (NOT FLATC)
+ message(SEND_ERROR "flatc not found. Specify the full path of the flatc executable with -DFLATC=<flatc path>")
+ endif()
+
+ add_custom_command(
+ # Generate an ClContextSchema_generated.h file if it doesn't exist, or update it when necessary otherwise
+ OUTPUT ClContextSchema_generated.h DEPENDS ClContextSchema.fbs
+ COMMAND ${FLATC} -o ${CMAKE_CURRENT_BINARY_DIR} --cpp ${CMAKE_CURRENT_SOURCE_DIR}/ClContextSchema.fbs
+ #COMMAND cp ${CMAKE_CURRENT_BINARY_DIR}/ClContextSchema_generated.h
+ # ${CMAKE_CURRENT_SOURCE_DIR}/ClContextSchema_generated.h
+ )
+
list(APPEND armnnClBackend_sources
+ ClContextSchema_generated.h
ClBackend.cpp
ClBackend.hpp
ClBackendContext.cpp
@@ -14,6 +30,10 @@ if(ARMCOMPUTECL)
ClBackendModelContext.hpp
ClContextControl.cpp
ClContextControl.hpp
+ ClContextDeserializer.hpp
+ ClContextDeserializer.cpp
+ ClContextSerializer.hpp
+ ClContextSerializer.cpp
ClLayerSupport.cpp
ClLayerSupport.hpp
ClRegistryInitializer.cpp