aboutsummaryrefslogtreecommitdiff
path: root/src/backends/backendsCommon/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMatteo Martincigh <matteo.martincigh@arm.com>2019-07-26 15:12:47 +0100
committerMatteo Martincigh <matteo.martincigh@arm.com>2019-07-30 12:24:14 +0100
commit986c186468e6023b234c24bd10ed9687f9eea0da (patch)
tree0f78d3221922a5730f13d8348cc930a9d0a63351 /src/backends/backendsCommon/test/CMakeLists.txt
parent1a81630bd9e633150be51366b4a01f9e859f84a8 (diff)
downloadarmnn-986c186468e6023b234c24bd10ed9687f9eea0da.tar.gz
IVGCVSW-3555 Add unit tests for the dynamic backend utility functions
* Added a test library to exercise the utility functions that handle the shared objects Signed-off-by: Matteo Martincigh <matteo.martincigh@arm.com> Change-Id: Ic8095febca2a46050831eb42f55a714f3ae3bfe3
Diffstat (limited to 'src/backends/backendsCommon/test/CMakeLists.txt')
-rw-r--r--src/backends/backendsCommon/test/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/backends/backendsCommon/test/CMakeLists.txt b/src/backends/backendsCommon/test/CMakeLists.txt
index 3ddaaaf162..4131b9e787 100644
--- a/src/backends/backendsCommon/test/CMakeLists.txt
+++ b/src/backends/backendsCommon/test/CMakeLists.txt
@@ -64,3 +64,14 @@ add_library(armnnBackendsCommonUnitTests OBJECT ${armnnBackendsCommonUnitTests_s
target_include_directories(armnnBackendsCommonUnitTests PRIVATE ${PROJECT_SOURCE_DIR}/src/armnn)
target_include_directories(armnnBackendsCommonUnitTests PRIVATE ${PROJECT_SOURCE_DIR}/src/armnnUtils)
target_include_directories(armnnBackendsCommonUnitTests PRIVATE ${PROJECT_SOURCE_DIR}/src/backends)
+
+# Dummy shared object for testing.
+# This is a simple library used to test the utility functions that will be used to handle the shared objects.
+
+list(APPEND armnnTestSharedObject_sources
+ TestSharedObject.cpp
+ TestSharedObject.hpp
+)
+
+add_library_ex(armnnTestSharedObject SHARED ${armnnTestSharedObject_sources})
+file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/libarmnnNoSharedObject.txt "This is not a shared object")