aboutsummaryrefslogtreecommitdiff
path: root/src/backends/backendsCommon/CMakeLists.txt
diff options
context:
space:
mode:
authorMatteo Martincigh <matteo.martincigh@arm.com>2019-08-01 17:09:03 +0100
committerMatteo Martincigh <matteo.martincigh@arm.com>2019-08-02 17:26:39 +0100
commitd0dc770aeb9423081a1ef0245f7449dcf3fb2ee2 (patch)
tree9943dc9d95200eda938c7996fe4a0f65177a9a4d /src/backends/backendsCommon/CMakeLists.txt
parentae7b832a6f5eda4b28577f57909111135a36dee9 (diff)
downloadarmnn-d0dc770aeb9423081a1ef0245f7449dcf3fb2ee2.tar.gz
IVGCVSW-3561 Fix the linker issues of the test shared objects in
the Android builds * Changed the test libs from SHARED to MODULE * Added IBackendInternal.cpp to separate the default implementation of OptimizeSubgraphView from the header file * Linked the modules against armnn to get the missing symbols * Renamed the test modules to avoid name clashing in the CI system * Moved the test shared objects to separate folders to keep the filesystem tidy Change-Id: I987c56d2d66bdb86f7b391a83c602d0dadf4c674 Signed-off-by: Matteo Martincigh <matteo.martincigh@arm.com>
Diffstat (limited to 'src/backends/backendsCommon/CMakeLists.txt')
-rw-r--r--src/backends/backendsCommon/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/backends/backendsCommon/CMakeLists.txt b/src/backends/backendsCommon/CMakeLists.txt
index 4048c58956..653f3727ee 100644
--- a/src/backends/backendsCommon/CMakeLists.txt
+++ b/src/backends/backendsCommon/CMakeLists.txt
@@ -13,6 +13,7 @@ list(APPEND armnnBackendsCommon_sources
DynamicBackend.hpp
DynamicBackendUtils.cpp
DynamicBackendUtils.hpp
+ IBackendInternal.cpp
IBackendInternal.hpp
IBackendContext.hpp
ITensorHandleFactory.cpp