aboutsummaryrefslogtreecommitdiff
path: root/profiling/server/src/basePipeServer/CMakeLists.txt
diff options
context:
space:
mode:
authorRob Hughes <robert.hughes@arm.com>2020-04-24 11:41:34 +0100
committerRob Hughes <robert.hughes@arm.com>2020-05-19 10:54:15 +0000
commitb98032f6a46072fee9a2bfcbe631b8193ced567d (patch)
tree1de423d3271e9ecbc0d02b8f08751c9eefa29612 /profiling/server/src/basePipeServer/CMakeLists.txt
parented324051794a262a7694acfb0a378724d6ba8401 (diff)
downloadarmnn-b98032f6a46072fee9a2bfcbe631b8193ced567d.tar.gz
Fix some Windows build errors:
* Cast to correct datatype for Winsock API * Replace non-standard u_int32_t * Add missing link dependency of timelineDecoder on armnn * Don't try to link pthread if the platform doesn't have it * Use abstracted Socket type rather than int * Link to WinSock DLL on windows Change-Id: I9ace4af50257ce1e3da92fb4c452f36775dac973 Signed-off-by: Robert Hughes <robert.hughes@arm.com>
Diffstat (limited to 'profiling/server/src/basePipeServer/CMakeLists.txt')
-rw-r--r--profiling/server/src/basePipeServer/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/profiling/server/src/basePipeServer/CMakeLists.txt b/profiling/server/src/basePipeServer/CMakeLists.txt
index b2cb82d816..a2567cede6 100644
--- a/profiling/server/src/basePipeServer/CMakeLists.txt
+++ b/profiling/server/src/basePipeServer/CMakeLists.txt
@@ -24,6 +24,11 @@ if(BUILD_BASE_PIPE_SERVER)
set_target_properties(armnnBasePipeServer PROPERTIES VERSION ${GENERIC_LIB_VERSION}
SOVERSION ${GENERIC_LIB_SOVERSION})
+ target_link_libraries(armnnBasePipeServer armnn)
+ if ("${CMAKE_SYSTEM_NAME}" STREQUAL Windows)
+ target_link_libraries(armnnBasePipeServer Ws2_32.lib)
+ endif()
+
install(TARGETS armnnBasePipeServer
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})