aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancis Murtagh <francis.murtagh@arm.com>2019-09-20 15:40:09 +0100
committerFrancis Murtagh <francis.murtagh@arm.com>2019-09-20 15:30:54 +0000
commitfcb8ef6b36873d06ddae7553aad28e726aa5be33 (patch)
tree4c1cf74a38ebfcf8c134bdb1b25568c04ca90e09 /CMakeLists.txt
parentda9d2d34ae57e18f631d4b42ad694a1d48270fe7 (diff)
downloadarmnn-fcb8ef6b36873d06ddae7553aad28e726aa5be33.tar.gz
IVGCVSW-3433 Create the Periodic Counter Capture Thread
* Add Periodic counter thread object * Add Unit test for thread * Move MockBuffer to header file to allow reuse Change-Id: Id2a8ea636723ab35e8a50efc200c8c76059bba02 Signed-off-by: Ferran Balaguer <ferran.balaguer@arm.com> Signed-off-by: Francis Murtagh <francis.murtagh@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6556c102bf..ef09fc02b2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -440,10 +440,13 @@ list(APPEND armnn_sources
src/profiling/ISendCounterPacket.hpp
src/profiling/IPeriodicCounterCapture.hpp
src/profiling/IProfilingConnection.hpp
+ src/profiling/IReadCounterValue.hpp
src/profiling/Packet.cpp
src/profiling/Packet.hpp
src/profiling/PacketVersionResolver.cpp
src/profiling/PacketVersionResolver.hpp
+ src/profiling/PeriodicCounterCapture.hpp
+ src/profiling/PeriodicCounterCapture.cpp
src/profiling/PeriodicCounterSelectionCommandHandler.cpp
src/profiling/PeriodicCounterSelectionCommandHandler.hpp
src/profiling/ProfilingConnectionFactory.cpp