aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFinn Williams <Finn.Williams@arm.com>2019-10-22 10:30:49 +0100
committerDavid Monahan <david.monahan@arm.com>2019-11-07 12:20:47 +0000
commite63a026bd987e78bdaa5b94c3e53201b62011faa (patch)
treecad6e7dcc7107b723ecc92116a96eda80100a99e /CMakeLists.txt
parent362e03214ceceb95ec30d530ff84e8d9efc198d7 (diff)
downloadarmnn-e63a026bd987e78bdaa5b94c3e53201b62011faa.tar.gz
IVGCVSW-3951 Create the timeline decoder
* Added ITimelineDecoder.h C interface * Added an example implementation of ITimelineDecoder.h * Added command handlers for the timeline directory and objects * Added tests for the decoder implementation * Changed ReadSwTraceMessage to take a const unsigned char* so it can be used by the directory command handler * Fixed some bugs in ProfilingUtils.cpp and related tests Change-Id: If06faf1fe0274a8f022f194a6d3527f5ce5374c6 Signed-off-by: Finn Williams <Finn.Williams@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 867fb34071..5b80430d7d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -822,6 +822,7 @@ if(BUILD_UNIT_TESTS)
if(BUILD_GATORD_MOCK)
list(APPEND unittest_sources
tests/profiling/gatordmock/tests/GatordMockTests.cpp
+ tests/profiling/timelineDecoder/tests/TimelineTests.cpp
)
endif()
@@ -936,6 +937,13 @@ if(BUILD_GATORD_MOCK)
tests/profiling/gatordmock/PeriodicCounterCaptureCommandHandler.hpp
tests/profiling/gatordmock/PeriodicCounterSelectionResponseHandler.cpp
tests/profiling/gatordmock/PeriodicCounterSelectionResponseHandler.hpp
+ tests/profiling/timelineDecoder/ITimelineDecoder.h
+ tests/profiling/timelineDecoder/TimelineCaptureCommandHandler.cpp
+ tests/profiling/timelineDecoder/TimelineCaptureCommandHandler.hpp
+ tests/profiling/timelineDecoder/TimelineDecoder.cpp
+ tests/profiling/timelineDecoder/TimelineDirectoryCaptureCommandHandler.cpp
+ tests/profiling/timelineDecoder/TimelineDirectoryCaptureCommandHandler.hpp
+ tests/profiling/timelineDecoder/tests/TimelineTestFunctions.hpp
)
include_directories(${Boost_INCLUDE_DIRS} src/profiling)