aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAron Virginas-Tar <Aron.Virginas-Tar@arm.com>2019-09-24 18:24:47 +0100
committerÁron Virginás-Tar <aron.virginas-tar@arm.com>2019-09-27 15:48:18 +0000
commitdfa1477f8144c8ae933f949f0cc6ab70b6ba372d (patch)
tree261804170b87e5d37633c276b7709f69868ff8e7 /CMakeLists.txt
parent3a7d3a70d99cbe22f5e4711d5dbbea2a245da7ed (diff)
downloadarmnn-dfa1477f8144c8ae933f949f0cc6ab70b6ba372d.tar.gz
IVGCVSW-3442 Add ProfilingConnectionDumpToFileDecorator
Signed-off-by: Aron Virginas-Tar <Aron.Virginas-Tar@arm.com> Change-Id: I3a8313287c69268ae02b6a65103363e9fbba6b4a
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a2febe3066..11afe7ad17 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -455,6 +455,8 @@ list(APPEND armnn_sources
src/profiling/PeriodicCounterCapture.cpp
src/profiling/PeriodicCounterSelectionCommandHandler.cpp
src/profiling/PeriodicCounterSelectionCommandHandler.hpp
+ src/profiling/ProfilingConnectionDumpToFileDecorator.cpp
+ src/profiling/ProfilingConnectionDumpToFileDecorator.hpp
src/profiling/ProfilingConnectionFactory.cpp
src/profiling/ProfilingConnectionFactory.hpp
src/profiling/ProfilingService.cpp
@@ -588,6 +590,7 @@ if(BUILD_UNIT_TESTS)
src/armnnUtils/test/PrototxtConversionsTest.cpp
src/armnnUtils/test/ParserHelperTest.cpp
src/armnnUtils/test/TensorUtilsTest.cpp
+ src/profiling/test/ProfilingConnectionDumpToFileDecoratorTests.cpp
src/profiling/test/ProfilingTests.cpp
src/profiling/test/SendCounterPacketTests.cpp
)