aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatteo Martincigh <matteo.martincigh@arm.com>2019-11-08 11:23:06 +0000
committerMatteo Martincigh <matteo.martincigh@arm.com>2019-11-15 15:34:20 +0000
commitcdfb9417ddce28a5cbd33f8049a147168a26aa9b (patch)
tree925ebcb589cff2a118cd47dfbaf5d1a5daf058ea /CMakeLists.txt
parent34a407d4a95830ff9fad05e2bff34dcfc631c931 (diff)
downloadarmnn-cdfb9417ddce28a5cbd33f8049a147168a26aa9b.tar.gz
IVGCVSW-4073 Send stream info in the ConnectionAcknowledgedCommandHandler
* Added call to ISendTimelinePacket::SendStreamMetaDataPacket * Added call to ISendTimelinePacket::SendTimelineMessageDirectoryPackage * Added new StreamMetadataCommandHandler class to the mock Gatord service * Updated code and unit tests * Added include paths to the gatord mock target Signed-off-by: Matteo Martincigh <matteo.martincigh@arm.com> Change-Id: Ic6d200b513175884607b7c0563cbfa4942ff2fc6
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fe3240d0a9..f088a21bd5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -936,6 +936,8 @@ if(BUILD_GATORD_MOCK)
tests/profiling/gatordmock/PeriodicCounterCaptureCommandHandler.hpp
tests/profiling/gatordmock/PeriodicCounterSelectionResponseHandler.cpp
tests/profiling/gatordmock/PeriodicCounterSelectionResponseHandler.hpp
+ tests/profiling/gatordmock/StreamMetadataCommandHandler.cpp
+ tests/profiling/gatordmock/StreamMetadataCommandHandler.hpp
tests/profiling/timelineDecoder/ITimelineDecoder.h
tests/profiling/timelineDecoder/TimelineCaptureCommandHandler.cpp
tests/profiling/timelineDecoder/TimelineCaptureCommandHandler.hpp
@@ -946,6 +948,9 @@ if(BUILD_GATORD_MOCK)
)
include_directories(${Boost_INCLUDE_DIRS} src/profiling)
+ include_directories(${Boost_INCLUDE_DIRS} tests/profiling)
+ include_directories(${Boost_INCLUDE_DIRS} tests/profiling/gatordmock)
+ include_directories(${Boost_INCLUDE_DIRS} tests/profiling/timelineDecoder)
add_library_ex(gatordMockService STATIC ${gatord_mock_sources})