aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNarumol Prangnawarat <narumol.prangnawarat@arm.com>2019-09-27 18:00:11 +0100
committerMatteo Martincigh <matteo.martincigh@arm.com>2019-09-30 14:00:10 +0000
commit7be47efac07b6276f02a17cb486f9061a426a837 (patch)
treeb63cc8dddef79b6540c9b2abae03055bf85bb685 /CMakeLists.txt
parentaab82c5ebc5b65f5f5f657d7bee6bd60f106d3b9 (diff)
downloadarmnn-7be47efac07b6276f02a17cb486f9061a426a837.tar.gz
IVGCVSW-3903 Create Counter Stream Buffer
* Add implementation of PacketBuffer * Add implementation of BufferManager * Unit tests Signed-off-by: Narumol Prangnawarat <narumol.prangnawarat@arm.com> Change-Id: Icca3807149ff5a8ed31cc87de73c50b95bca39d4
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 11afe7ad17..6ae352d94c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -424,6 +424,8 @@ list(APPEND armnn_sources
src/armnn/optimizations/PermuteAndBatchToSpaceAsDepthToSpace.cpp
src/armnn/optimizations/PermuteAsReshape.hpp
src/armnn/optimizations/SquashEqualSiblings.hpp
+ src/profiling/BufferManager.cpp
+ src/profiling/BufferManager.hpp
src/profiling/CommandHandlerFunctor.cpp
src/profiling/CommandHandlerFunctor.hpp
src/profiling/CommandHandlerKey.cpp
@@ -449,6 +451,8 @@ list(APPEND armnn_sources
src/profiling/IReadCounterValue.hpp
src/profiling/Packet.cpp
src/profiling/Packet.hpp
+ src/profiling/PacketBuffer.cpp
+ src/profiling/PacketBuffer.hpp
src/profiling/PacketVersionResolver.cpp
src/profiling/PacketVersionResolver.hpp
src/profiling/PeriodicCounterCapture.hpp
@@ -590,6 +594,7 @@ if(BUILD_UNIT_TESTS)
src/armnnUtils/test/PrototxtConversionsTest.cpp
src/armnnUtils/test/ParserHelperTest.cpp
src/armnnUtils/test/TensorUtilsTest.cpp
+ src/profiling/test/BufferTests.cpp
src/profiling/test/ProfilingConnectionDumpToFileDecoratorTests.cpp
src/profiling/test/ProfilingTests.cpp
src/profiling/test/SendCounterPacketTests.cpp