aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSadik Armagan <sadik.armagan@arm.com>2019-10-24 10:26:05 +0100
committerJim Flynn Arm <jim.flynn@arm.com>2019-10-24 10:06:40 +0000
commit7bbdf9db051f40377a284a28375816e60349376d (patch)
treedc7d8442cecb2f23ca2f93c8535316ed5207be69 /CMakeLists.txt
parenta87698211b6aaab38424865d200534d96f55dcf2 (diff)
downloadarmnn-7bbdf9db051f40377a284a28375816e60349376d.tar.gz
IVGCVSW-3950 Create SendTimelinePacket interface and class
* Implemented ISendTimelinePacket interface and its implementation SendTimelinePacket * Implemented TimelinePacketWriterFactory * Implemented unit tests for SendTimelinePacket functions Signed-off-by: Sadik Armagan <sadik.armagan@arm.com> Change-Id: I0a47586437f99510394d4d94589dccfb397d38e5
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d686d3f68e..e3b1f8feba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -455,6 +455,7 @@ list(APPEND armnn_sources
src/profiling/ICounterDirectory.hpp
src/profiling/ICounterValues.hpp
src/profiling/ISendCounterPacket.hpp
+ src/profiling/ISendTimelinePacket.hpp
src/profiling/IPacketBuffer.hpp
src/profiling/IPeriodicCounterCapture.hpp
src/profiling/IProfilingConnection.hpp
@@ -486,8 +487,12 @@ list(APPEND armnn_sources
src/profiling/RequestCounterDirectoryCommandHandler.hpp
src/profiling/SendCounterPacket.cpp
src/profiling/SendCounterPacket.hpp
+ src/profiling/SendTimelinePacket.cpp
+ src/profiling/SendTimelinePacket.hpp
src/profiling/SocketProfilingConnection.cpp
src/profiling/SocketProfilingConnection.hpp
+ src/profiling/TimelinePacketWriterFactory.cpp
+ src/profiling/TimelinePacketWriterFactory.hpp
third-party/half/half.hpp
)
@@ -616,6 +621,7 @@ if(BUILD_UNIT_TESTS)
src/profiling/test/ProfilingTests.hpp
src/profiling/test/SendCounterPacketTests.cpp
src/profiling/test/SendCounterPacketTests.hpp
+ src/profiling/test/SendTimelinePacketTests.cpp
src/profiling/test/TimelinePacketTests.cpp
)