aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRob Hughes <robert.hughes@arm.com>2019-11-15 09:04:17 +0000
committerDerek Lamberti <derek.lamberti@arm.com>2019-11-15 13:10:56 +0000
commit721b82f257afae0170a60ba355efceef6cff2355 (patch)
tree8beb627dee8979e284210024c1bd329821174325 /CMakeLists.txt
parentdb1a2834b4e9d74ed538943634212eccbd4a789b (diff)
downloadarmnn-721b82f257afae0170a60ba355efceef6cff2355.tar.gz
Print CMake messages on stdout rather than stderr
The default version of message("...") print to stderr, which is inappropriate for informational messages such as the ones we are printing in these cases. Using message(STATUS "...") makes these messages appear on stdout instead which is more appropriate. Change-Id: I02f41e6b4948e6938566f06d7164444bd5b8199e Signed-off-by: Robert Hughes <robert.hughes@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 89f0e5af56..fe3240d0a9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -518,7 +518,7 @@ endif()
# object libs armnn to include in the build
include(src/backends/backends.cmake)
foreach(lib ${armnnLibraries})
- message("Adding object library dependency to armnn: ${lib}")
+ message(STATUS "Adding object library dependency to armnn: ${lib}")
list(APPEND armnn_sources $<TARGET_OBJECTS:${lib}>)
endforeach()
@@ -826,7 +826,7 @@ if(BUILD_UNIT_TESTS)
endif()
foreach(lib ${armnnUnitTestLibraries})
- message("Adding object library dependency to UnitTests: ${lib}")
+ message(STATUS "Adding object library dependency to UnitTests: ${lib}")
list(APPEND unittest_sources $<TARGET_OBJECTS:${lib}>)
endforeach()
@@ -838,7 +838,7 @@ if(BUILD_UNIT_TESTS)
if(VALGRIND_FOUND)
if(HEAP_PROFILING OR LEAK_CHECKING)
- message("Valgrind is disabled for heap profiling and leak checking builds.")
+ message(STATUS "Valgrind is disabled for heap profiling and leak checking builds.")
else()
# Valgrind works with gperftools version number <= 2.4
target_compile_definitions(UnitTests PRIVATE "WITH_VALGRIND=1")