aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatteo Martincigh <matteo.martincigh@arm.com>2019-10-17 13:26:21 +0100
committerMatteo Martincigh <matteo.martincigh@arm.com>2019-10-17 13:34:28 +0100
commit6598427f7dc68f2c9ef6d683e80ec4627df52d58 (patch)
tree8fc60f90d77f45394454f2ab568394a04cac5cff /CMakeLists.txt
parent7e5eec7d06c1f753b13af653eacd476c0b68efcc (diff)
downloadarmnn-6598427f7dc68f2c9ef6d683e80ec4627df52d58.tar.gz
IVGCVSW-3400 Fixed include directives for Gatord builds
* Using proper include directives with include paths * The relative paths used were causing trouble when building on other CI systems Signed-off-by: Matteo Martincigh <matteo.martincigh@arm.com> Change-Id: I897a80d1f56fbdbc3c714a50a0598210d8f0a03c
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6bc6573a96..499f721eb5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -905,7 +905,7 @@ if(BUILD_GATORD_MOCK)
tests/profiling/gatordmock/PeriodicCounterCaptureCommandHandler.hpp
)
- include_directories( ${Boost_INCLUDE_DIRS} src/profiling)
+ include_directories(${Boost_INCLUDE_DIRS} src/profiling)
add_library_ex(gatordMockService STATIC ${gatord_mock_sources})
@@ -915,9 +915,10 @@ if(BUILD_GATORD_MOCK)
target_link_libraries(GartordMock pthread)
endif()
- target_link_libraries(GartordMock armnn gatordMockService)
target_link_libraries(GartordMock
- ${Boost_PROGRAM_OPTIONS_LIBRARY} ${Boost_SYSTEM_LIBRARY}
- )
+ armnn
+ gatordMockService
+ ${Boost_PROGRAM_OPTIONS_LIBRARY}
+ ${Boost_SYSTEM_LIBRARY})
endif()