aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authornarpra01 <narumol.prangnawarat@arm.com>2018-12-21 18:30:00 +0000
committerLes Bell <les.bell@arm.com>2019-01-02 09:25:42 +0000
commit6f37f83a27160948fee366b9f195c52f78cb88f0 (patch)
treed09a8d5769c3ac2c8f45660d305e9a6124716310 /CMakeLists.txt
parentc48ac8c8cea1748ebfef15144f070799d4a129c3 (diff)
downloadarmnn-6f37f83a27160948fee366b9f195c52f78cb88f0.tar.gz
IVGCVSW-2353 Ignore control inputs in TensorFlow parser
* Allow control inputs from TensorFlow graph but ignore them in ArmNN graph. * Add utility function to test ArmNN graph structure. * Add ArmNN graph structure tests in TensorFlow paresr to ensure that control inputs are ignored in ArmNN graph as well as their inputs that are not used anywhere else. Change-Id: Ib0ea0d2df85e3fc79b748fa4c9d20e0649352bc1
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index be68798281..22725aeef4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -367,6 +367,7 @@ if(BUILD_UNIT_TESTS)
src/armnn/test/EndToEndTest.cpp
src/armnn/test/FloatingPointConverterTest.cpp
src/armnn/test/GraphTests.cpp
+ src/armnn/test/GraphUtils.cpp
src/armnn/test/GraphUtils.hpp
src/armnn/test/InstrumentTests.cpp
src/armnn/test/LayerValidateOutputTest.cpp
@@ -390,6 +391,7 @@ if(BUILD_UNIT_TESTS)
src/armnnTfParser/test/Activations.cpp
src/armnnTfParser/test/Addition.cpp
src/armnnTfParser/test/AddN.cpp
+ src/armnnTfParser/test/Assert.cpp
src/armnnTfParser/test/BiasAdd.cpp
src/armnnTfParser/test/BroadcastForAdd.cpp
src/armnnTfParser/test/Convolution2d.cpp