aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Beck <david.beck@arm.com>2018-10-10 15:11:44 +0100
committerMatthew Bentham <matthew.bentham@arm.com>2018-10-22 16:57:53 +0100
commit9df2d951616e3d76b67a9852d5324de96633f0f9 (patch)
tree37a57a98ef8aafba748d332bfc686e2b022398d6 /CMakeLists.txt
parent6b779f0e437127bfa71a529e9b848b5e41683ab8 (diff)
downloadarmnn-9df2d951616e3d76b67a9852d5324de96633f0f9.tar.gz
IVGCVSW-1952 : add BackendId class to prepare for the replacement of Compute enum
!armnn:152674 Change-Id: I1bcdfdfbfb73e502d58f35717e2558e24651013c
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 501da806ad..dfda4d1d93 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -147,18 +147,23 @@ endif()
list(APPEND armnn_sources
include/armnn/ArmNN.hpp
+ include/armnn/BackendId.hpp
include/armnn/Descriptors.hpp
include/armnn/DescriptorsFwd.hpp
- include/armnn/IRuntime.hpp
+ include/armnn/Exceptions.hpp
include/armnn/ILayerSupport.hpp
include/armnn/INetwork.hpp
+ include/armnn/IProfiler.hpp
+ include/armnn/IRuntime.hpp
+ include/armnn/LayerSupport.hpp
+ include/armnn/LstmParams.hpp
+ include/armnn/NetworkFwd.hpp
include/armnn/Optional.hpp
include/armnn/Tensor.hpp
include/armnn/TensorFwd.hpp
include/armnn/Types.hpp
include/armnn/TypesUtils.hpp
include/armnn/Utils.hpp
- include/armnn/LayerSupport.hpp
include/armnn/Version.hpp
src/armnn/layers/LayerCloneBase.hpp
src/armnn/layers/LayerWithParameters.hpp
@@ -378,6 +383,7 @@ if(BUILD_UNIT_TESTS)
src/armnn/test/InstrumentTests.cpp
src/armnn/test/ObservableTest.cpp
src/armnn/test/OptionalTest.cpp
+ src/backends/test/BackendIdTests.cpp
src/backends/test/BackendRegistryTests.cpp
src/backends/test/IsLayerSupportedTestImpl.hpp
src/backends/test/WorkloadDataValidation.cpp