aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSadik Armagan <sadik.armagan@arm.com>2018-10-01 11:51:37 +0100
committerMatthew Bentham <matthew.bentham@arm.com>2018-10-10 16:16:57 +0100
commit479045bdcac4faddbf567aa0f73d2899881f341c (patch)
tree5cd11ee39543ceda2730d21c1e7036543712a335 /CMakeLists.txt
parente4ba53a85c559d4fe574305276ac815cf7995762 (diff)
downloadarmnn-479045bdcac4faddbf567aa0f73d2899881f341c.tar.gz
IVGCVSW-1787 Add Support for Concatenation on TfLite parser
* Concatenation Parser function added to the TfLite Parser Change-Id: I42a42cd765ea09a30841c66b1942b9e09a876b10
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cfbbae6808..8d77d91c49 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,6 +43,8 @@ list(APPEND armnnUtils_sources
src/armnnUtils/FloatingPointConverter.hpp
src/armnnUtils/VerificationHelpers.hpp
src/armnnUtils/VerificationHelpers.cpp
+ src/armnnUtils/ParserHelper.hpp
+ src/armnnUtils/ParserHelper.cpp
)
if(BUILD_TF_PARSER OR BUILD_CAFFE_PARSER)
list(APPEND armnnUtils_sources
@@ -452,9 +454,12 @@ if(BUILD_UNIT_TESTS)
if(BUILD_TF_LITE_PARSER)
list(APPEND unittest_sources
src/armnnTfLiteParser/test/ParserFlatbuffersFixture.hpp
+ src/armnnTfLiteParser/test/Activations.cpp
src/armnnTfLiteParser/test/AvgPool2D.cpp
+ src/armnnTfLiteParser/test/Concatenation.cpp
src/armnnTfLiteParser/test/Conv2D.cpp
src/armnnTfLiteParser/test/DepthwiseConvolution2D.cpp
+ src/armnnTfLiteParser/test/Reshape.cpp
src/armnnTfLiteParser/test/Softmax.cpp
src/armnnTfLiteParser/test/Squeeze.cpp
src/armnnTfLiteParser/test/LoadModel.cpp
@@ -464,8 +469,6 @@ if(BUILD_UNIT_TESTS)
src/armnnTfLiteParser/test/GetTensorIds.cpp
src/armnnTfLiteParser/test/GetSubgraphInputsOutputs.cpp
src/armnnTfLiteParser/test/GetInputsOutputs.cpp
- src/armnnTfLiteParser/test/Activations.cpp
- src/armnnTfLiteParser/test/Reshape.cpp
)
endif()