aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAron Virginas-Tar <Aron.Virginas-Tar@arm.com>2018-10-12 13:00:55 +0100
committerMatthew Bentham <matthew.bentham@arm.com>2018-10-22 16:57:53 +0100
commit3b278e9261bd0de67c82f7d6c36731f118124f52 (patch)
tree3750ee01827809141752302e94d4d25a21f88492 /CMakeLists.txt
parentd3360cd490eafc76ceddb6760054bd80444179c1 (diff)
downloadarmnn-3b278e9261bd0de67c82f7d6c36731f118124f52.tar.gz
IVGCVSW-1938: Move backend-specific source files to the corresponding backend
Change-Id: I558a9a007604afc55e536d877f8da7d0215cc9c3
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt33
1 files changed, 0 insertions, 33 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7325d40303..1956643fb7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -277,21 +277,6 @@ list(APPEND armnn_sources
src/armnn/Observable.cpp
)
-if(ARMCOMPUTENEON)
- # Additionally include source files for ARM Compute NEON backend
- list(APPEND armnn_sources
- src/armnn/NeonInterceptorScheduler.hpp
- src/armnn/NeonInterceptorScheduler.cpp
- src/armnn/NeonTimer.hpp
- src/armnn/NeonTimer.cpp)
-endif()
-if(ARMCOMPUTECL)
- # Additionally include source files for ARM Compute OpenCL backend
- list(APPEND armnn_sources
- src/armnn/OpenClTimer.cpp
- src/armnn/OpenClTimer.hpp)
-endif()
-# Files shared by all ARM Compute backends
if(ARMCOMPUTENEON OR ARMCOMPUTECL)
list(APPEND armnn_sources
src/armnn/memory/IMemoryPool.hpp
@@ -405,24 +390,6 @@ if(BUILD_UNIT_TESTS)
src/backends/test/WorkloadTestUtils.hpp
src/backends/test/QuantizeHelper.hpp)
- if(ARMCOMPUTENEON)
- list(APPEND unittest_sources
- src/armnn/test/CreateWorkloadClNeon.hpp
- src/armnn/test/NeonTimerTest.cpp)
- endif()
-
- if(ARMCOMPUTECL)
- list(APPEND unittest_sources
- src/armnn/test/CreateWorkloadClNeon.hpp
- src/armnn/test/OpenClTimerTest.cpp
- src/armnn/test/FP16SupportTest.cpp)
- endif()
-
- if(ARMCOMPUTENEON OR ARMCOMPUTECL)
- list(APPEND unittest_sources
- src/backends/test/MemCopyTests.cpp)
- endif()
-
if(BUILD_TF_PARSER)
list(APPEND unittest_sources
src/armnnTfParser/test/Activations.cpp