aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFinn Williams <Finn.Williams@arm.com>2020-11-25 14:32:42 +0000
committerfinn.williams <finn.williams@arm.com>2020-11-30 17:00:41 +0000
commitbbbefecd34a9420bcb003dd230402c55ee5150d5 (patch)
treea2a75780106abfa81e14d6e11f568e395bcb67de /CMakeLists.txt
parent31c39be002b9e9040b2306e2461ee228853b4ed6 (diff)
downloadarmnn-bbbefecd34a9420bcb003dd230402c55ee5150d5.tar.gz
IVGCVSW-5587 Remove Tensorflow requirement from Arm NN TfLite delegate
* Added support for building the delegate with an external armnn path * Replaced potentially troublesome package manager * Explicitly set the privacy levels of delegate libraries * Fixed some error handling in ExecuteNetwork Signed-off-by: Finn Williams <Finn.Williams@arm.com> Change-Id: I2a7abc099796012cbb043c5b319f81778c9f3b56
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cee3c2a020..763c010d56 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,10 +41,8 @@ add_subdirectory(src/armnnDeserializer)
if (BUILD_ARMNN_TFLITE_DELEGATE)
-
- list(APPEND CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/delegate/cmake/Modules)
+ set(ARMNN_SUB_PROJECT ON)
add_subdirectory(delegate)
-
add_definitions(-DARMNN_TF_LITE_DELEGATE)
endif()