aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFinn Williams <Finn.Williams@arm.com>2020-02-26 10:25:26 +0000
committerJim Flynn <jim.flynn@arm.com>2020-03-04 14:24:29 +0000
commit8a2b4685fde869c46ad4ebb19cbfefc4adc2a654 (patch)
tree4f4c87fe502ebbc595ff60ee588183e3b230ad7c /CMakeLists.txt
parenta97a0be5f16cb876d7226b733ac6aaa3b79dabd3 (diff)
downloadarmnn-8a2b4685fde869c46ad4ebb19cbfefc4adc2a654.tar.gz
IVGCVSW-4160 Make the ARM Developer Studio code a self contained build entity
!armnn:2773 Signed-off-by: Finn Williams <Finn.Williams@arm.com> Change-Id: I246cf0de04a1d29dd135cb0fc7e55bc5f0d4b854
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 5 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e3b794ab53..5da8133a39 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -864,7 +864,7 @@ if(BUILD_UNIT_TESTS)
if(BUILD_GATORD_MOCK)
list(APPEND unittest_sources
tests/profiling/gatordmock/tests/GatordMockTests.cpp
- tests/profiling/timelineDecoder/tests/TimelineTests.cpp
+ src/timelineDecoder/tests/TimelineTests.cpp
)
endif()
@@ -900,6 +900,7 @@ if(BUILD_UNIT_TESTS)
if(BUILD_GATORD_MOCK)
target_link_libraries(UnitTests gatordMockService)
+ target_link_libraries(UnitTests timelineDecoder)
endif()
if(BUILD_TF_LITE_PARSER)
@@ -967,6 +968,8 @@ if (BUILD_ARMNN_SERIALIZER AND (BUILD_TF_PARSER OR BUILD_TF_LITE_PARSER OR BUILD
endif()
if(BUILD_GATORD_MOCK)
+ add_subdirectory(src/timelineDecoder)
+
set(gatord_mock_sources)
list(APPEND gatord_mock_sources
tests/profiling/gatordmock/CommandFileParser.hpp
@@ -981,19 +984,9 @@ if(BUILD_GATORD_MOCK)
tests/profiling/gatordmock/PeriodicCounterSelectionResponseHandler.hpp
tests/profiling/gatordmock/StreamMetadataCommandHandler.cpp
tests/profiling/gatordmock/StreamMetadataCommandHandler.hpp
- tests/profiling/timelineDecoder/ITimelineDecoder.hpp
- tests/profiling/timelineDecoder/TimelineCaptureCommandHandler.cpp
- tests/profiling/timelineDecoder/TimelineCaptureCommandHandler.hpp
- tests/profiling/timelineDecoder/TimelineDecoder.cpp
- tests/profiling/timelineDecoder/TimelineDecoder.hpp
- tests/profiling/timelineDecoder/TimelineDirectoryCaptureCommandHandler.cpp
- tests/profiling/timelineDecoder/TimelineDirectoryCaptureCommandHandler.hpp
)
- include_directories(${Boost_INCLUDE_DIRS} src/profiling)
- include_directories(${Boost_INCLUDE_DIRS} tests/profiling)
- include_directories(${Boost_INCLUDE_DIRS} tests/profiling/gatordmock)
- include_directories(${Boost_INCLUDE_DIRS} tests/profiling/timelineDecoder)
+ include_directories(src/timelineDecoder src/profiling tests/profiling tests/profiling/gatordmock)
add_library_ex(gatordMockService STATIC ${gatord_mock_sources})
target_include_directories(gatordMockService PRIVATE src/armnnUtils)