aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKeith Davis <keith.davis@arm.com>2020-03-30 10:43:41 +0100
committerFinn Williams <Finn.Williams@arm.com>2020-04-02 16:56:24 +0100
commit33ed221e2e8e3a77b5f543061e0cce07b259fc64 (patch)
tree8467f2e4ce019bfa2837ae1030c321509414780c /CMakeLists.txt
parent0fe279bbf22fd2116b283b9df61076d526f115e4 (diff)
downloadarmnn-33ed221e2e8e3a77b5f543061e0cce07b259fc64.tar.gz
IVGCVSW-4455 Add an Activate and Deactivate control packet to the protocol
* Add Activate/Deactivate command handlers * Add IReportStructure, INotifyBackends single function interfaces * Add overrided mechanism to report structure in Runtime.cpp * Add overrided mechanism to notify backends in ProfilingService.cpp * Add optional IReportStructure argument to ProfilingService constructor for use in ActivateTimelineReportingCommandHandler * Refactoring and tidying up indentation * Removal of unused code in ProfilingUtils.cpp and ProfilingService.cpp * Added GatordMock end to end test * Fixed an issue with SendCounterPacket sending duplicate packets * Fixed an issue with DirectoryCaptureCommandHandler handling of Optional Signed-off-by: Keith Davis <keith.davis@arm.com> Signed-off-by: Finn Williams <Finn.Williams@arm.com> Change-Id: I5ef1b74171459bfc649861dedf99921d22c9e63f
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c093344acd..aac18e99cb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -462,6 +462,8 @@ list(APPEND armnn_sources
src/armnn/optimizations/PermuteAndBatchToSpaceAsDepthToSpace.hpp
src/armnn/optimizations/PermuteAsReshape.hpp
src/armnn/optimizations/SquashEqualSiblings.hpp
+ src/profiling/ActivateTimelineReportingCommandHandler.cpp
+ src/profiling/ActivateTimelineReportingCommandHandler.hpp
src/profiling/BufferManager.cpp
src/profiling/BufferManager.hpp
src/profiling/CommandHandler.cpp
@@ -478,6 +480,8 @@ list(APPEND armnn_sources
src/profiling/CounterDirectory.hpp
src/profiling/CounterIdMap.cpp
src/profiling/CounterIdMap.hpp
+ src/profiling/DeactivateTimelineReportingCommandHandler.cpp
+ src/profiling/DeactivateTimelineReportingCommandHandler.hpp
src/profiling/DirectoryCaptureCommandHandler.cpp
src/profiling/DirectoryCaptureCommandHandler.hpp
src/profiling/EncodeVersion.hpp
@@ -490,6 +494,8 @@ list(APPEND armnn_sources
src/profiling/ICounterDirectory.hpp
src/profiling/ICounterRegistry.hpp
src/profiling/ICounterValues.hpp
+ src/profiling/INotifyBackends.hpp
+ src/profiling/IReportStructure.hpp
src/profiling/ISendCounterPacket.hpp
src/profiling/ISendThread.hpp
src/profiling/IPacketBuffer.hpp