aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNarumol Prangnawarat <narumol.prangnawarat@arm.com>2019-09-24 17:23:16 +0100
committerNarumol Prangnawarat <narumol.prangnawarat@arm.com>2019-09-26 22:52:32 +0100
commit404b27569523f4cdd49752e7ae1633e359ba2190 (patch)
treeb2acd65aae6b285cbacfafe7a83b8873a1a5e79e /CMakeLists.txt
parente4ffe399de3445a1ecaf0ea8da7ff4f06ec878d3 (diff)
downloadarmnn-404b27569523f4cdd49752e7ae1633e359ba2190.tar.gz
IVGCVSW-3902 Create IReadOnlyPacketBuffer, IPacketBuffer and IBufferManager interfaces
* Create IReadOnlyPacketBuffer, IPacketBuffer and IBufferManager interfaces * Add Read and Write util functions that use IPacketBuffer * Add MockBufferManager using IBufferManager for testing * Modify SendCounterPacket to use IBufferManager * Modify MockStreamCounterBuffer to use IBufferManager * Remove IBufferWrapper and MockBuffer * Add MockPacketBuffer for testing * Modify unit tests to use the new interfaces Signed-off-by: Narumol Prangnawarat <narumol.prangnawarat@arm.com> Change-Id: Ib86768187e032f07169aa39367a418b7665c9f03
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6690e8624d..3e4d9c08d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -438,9 +438,10 @@ list(APPEND armnn_sources
src/profiling/EncodeVersion.hpp
src/profiling/Holder.cpp
src/profiling/Holder.hpp
- src/profiling/IBufferWrapper.hpp
+ src/profiling/IBufferManager.hpp
src/profiling/ICounterDirectory.hpp
src/profiling/ISendCounterPacket.hpp
+ src/profiling/IPacketBuffer.hpp
src/profiling/IPeriodicCounterCapture.hpp
src/profiling/IProfilingConnection.hpp
src/profiling/IReadCounterValue.hpp