aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Bentham <matthew.bentham@arm.com>2019-01-21 15:45:51 +0000
committerAron Virginas-Tar <Aron.Virginas-Tar@arm.com>2019-01-23 10:12:51 +0000
commit4057d91322738e446c0c2ce5f3a8cf665d935763 (patch)
tree352dff895fd187ed83d0448294505a76092c4bab /CMakeLists.txt
parent4951d84b1174a4bb0a5d9c900740f64201f765bf (diff)
downloadarmnn-4057d91322738e446c0c2ce5f3a8cf665d935763.tar.gz
IVGCVSW-2515 Fix compilation when TfParser is disabled
Change-Id: Ia0019134f76764cd4fe6ed9dc1423b8aba411d33
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 682e2cf688..82f7d11c7a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,14 +48,12 @@ list(APPEND armnnUtils_sources
src/armnnUtils/VerificationHelpers.cpp
src/armnnUtils/ParserHelper.hpp
src/armnnUtils/ParserHelper.cpp
+ src/armnnUtils/ParserPrototxtFixture.hpp
+ src/armnnUtils/PrototxtConversions.hpp
+ src/armnnUtils/PrototxtConversions.cpp
src/armnnUtils/TensorUtils.hpp
src/armnnUtils/TensorUtils.cpp
)
-if(BUILD_TF_PARSER OR BUILD_CAFFE_PARSER)
- list(APPEND armnnUtils_sources
- src/armnnUtils/ParserPrototxtFixture.hpp
- )
-endif()
add_library_ex(armnnUtils STATIC ${armnnUtils_sources})
@@ -394,7 +392,7 @@ if(BUILD_UNIT_TESTS)
src/armnn/test/UnitTests.cpp
src/armnn/test/UnitTests.hpp
src/armnn/test/UtilsTests.cpp
- src/armnnUtils/test/ParsePrototxtFixtureTest.cpp
+ src/armnnUtils/test/PrototxtConversionsTest.cpp
src/armnnUtils/test/ParserHelperTest.cpp
)