aboutsummaryrefslogtreecommitdiff
path: root/third_party/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/CMakeLists.txt')
-rw-r--r--third_party/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/third_party/CMakeLists.txt b/third_party/CMakeLists.txt
new file mode 100644
index 0000000..b26a94c
--- /dev/null
+++ b/third_party/CMakeLists.txt
@@ -0,0 +1,25 @@
+cmake_minimum_required (VERSION 3.13.4)
+
+# Copyright (c) 2020-2021, ARM Limited.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+
+set(CMAKE_INSTALL_PREFIX "./third_party" CACHE PATH "..." FORCE)
+
+project(third_party LANGUAGES CXX)
+
+# Flatbuffers tests are not needed
+set(FLATBUFFERS_BUILD_TESTS OFF)
+
+add_subdirectory(flatbuffers)