aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRob Elliott <Robert.Elliott@arm.com>2023-11-13 14:02:24 +0000
committerRob Elliott <Robert.Elliott@arm.com>2023-11-13 15:45:01 +0000
commit9bb9c4e67b42a1c6b3f3cc93c4f3a345856c010f (patch)
tree652bc79a1aa5608fa7e7168ccc8628f32ecc2250 /setup.py
parentcd914da80304592a6826e967d0d04b637d916718 (diff)
downloadserialization_lib-9bb9c4e67b42a1c6b3f3cc93c4f3a345856c010f.tar.gz
Add pyproject.toml to enable pip install
Signed-off-by: Rob Elliott <Robert.Elliott@arm.com> Change-Id: Ib052470d183db5a54a4cd26fc5df42e4c1bc5341
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 18 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..3008a9e
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,18 @@
+# Copyright (c) 2023, ARM Limited.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+"""Setup script for backward compatibility."""
+from setuptools import setup
+
+setup()