aboutsummaryrefslogtreecommitdiff
path: root/thirdparty/cxxopts/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'thirdparty/cxxopts/CMakeLists.txt')
-rw-r--r--thirdparty/cxxopts/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/thirdparty/cxxopts/CMakeLists.txt b/thirdparty/cxxopts/CMakeLists.txt
new file mode 100644
index 0000000..e81bf08
--- /dev/null
+++ b/thirdparty/cxxopts/CMakeLists.txt
@@ -0,0 +1,8 @@
+set(CXXOPTS_BUILD_EXAMPLES OFF CACHE INTERNAL "")
+set(CXXOPTS_BUILD_TESTS OFF CACHE INTERNAL "")
+FetchContent_GetProperties(cxxopts)
+if(NOT cxxopts_POPULATED)
+ FetchContent_Populate(cxxopts)
+ add_subdirectory(${cxxopts_SOURCE_DIR} ${cxxopts_BINARY_DIR} EXCLUDE_FROM_ALL)
+
+endif()