aboutsummaryrefslogtreecommitdiff
path: root/thirdparty/cxxopts/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Kunze <eric.kunze@arm.com>2022-06-22 11:30:23 -0700
committerEric Kunze <eric.kunze@arm.com>2022-08-22 22:59:54 +0000
commit286f834ce60e4ebcaaf131cb7da97ebf79098fa0 (patch)
tree83baf6a241912f980a0b1b311726fb5f7c97ac1e /thirdparty/cxxopts/CMakeLists.txt
parent3c59d5d2b4c20ec64daff76fd04a374c5a5055e0 (diff)
downloadreference_model-286f834ce60e4ebcaaf131cb7da97ebf79098fa0.tar.gz
Simplify the argument parsing and debug code
Change-Id: Ia681aa0eb1d42fa31a4658badb376f7b32b2e338 Signed-off-by: Eric Kunze <eric.kunze@arm.com>
Diffstat (limited to 'thirdparty/cxxopts/CMakeLists.txt')
-rw-r--r--thirdparty/cxxopts/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/thirdparty/cxxopts/CMakeLists.txt b/thirdparty/cxxopts/CMakeLists.txt
new file mode 100644
index 0000000..e81bf08
--- /dev/null
+++ b/thirdparty/cxxopts/CMakeLists.txt
@@ -0,0 +1,8 @@
+set(CXXOPTS_BUILD_EXAMPLES OFF CACHE INTERNAL "")
+set(CXXOPTS_BUILD_TESTS OFF CACHE INTERNAL "")
+FetchContent_GetProperties(cxxopts)
+if(NOT cxxopts_POPULATED)
+ FetchContent_Populate(cxxopts)
+ add_subdirectory(${cxxopts_SOURCE_DIR} ${cxxopts_BINARY_DIR} EXCLUDE_FROM_ALL)
+
+endif()