aboutsummaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorJeremy Johnson <jeremy.johnson@arm.com>2021-12-14 16:34:05 +0000
committerJeremy Johnson <jeremy.johnson@arm.com>2022-01-06 11:38:19 +0000
commit2ec3494060ffdafec072fe1b2099a8177b8eca6a (patch)
treefbe9d2dfdc4abeff9ba374a90065b7ed98e97509 /setup.cfg
parenta1d49853082f5454144209c1d95dc9203f510746 (diff)
downloadreference_model-2ec3494060ffdafec072fe1b2099a8177b8eca6a.tar.gz
Reorganize verif and create packages
Split generator and runner scripts Add package setup Add py-dev-env.sh/.bash to allow editing source files during dev Update README.md with installation info Signed-off-by: Jeremy Johnson <jeremy.johnson@arm.com> Change-Id: I172fe426d99e2e9aeeacedc8b8f3b6a79c8bd39d
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg40
1 files changed, 40 insertions, 0 deletions
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..5b7ffc4
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,40 @@
+# Copyright (c) 2021-2022 Arm Limited.
+# SPDX-License-Identifier: Apache-2.0
+
+[metadata]
+name = tosa-tools
+# version = done by setuptools_scm in pyproject.toml
+author = Arm Limited
+#author_email =
+description = TOSA tools
+long_description = file: README.md
+long_description_content_type = text/markdown
+url = https://git.mlplatform.org/tosa/reference_model.git/
+project_urls =
+ Website = https://developer.mlplatform.org/w/tosa/
+classifiers =
+ Programming Language :: Python :: 3
+ License :: OSI Approved :: Apache Software License
+ Operating System :: OS Independent
+
+[options]
+install_requires =
+ numpy
+ flatbuffers == 2.0
+python_requires = >=3.6
+packages =
+ runner
+ generator
+ xunit
+ tosa
+ serializer
+package_dir =
+ = verif
+ xunit = scripts/xunit
+ tosa = thirdparty/serialization_lib/python/tosa
+ serializer = thirdparty/serialization_lib/python/serializer
+
+[options.entry_points]
+console_scripts =
+ tosa_verif_run_ref = runner.tosa_verif_run_ref:main
+ tosa_verif_build_tests = generator.tosa_verif_build_tests:main