aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Kunze <eric.kunze@arm.com>2024-01-10 00:23:43 +0000
committerEric Kunze <eric.kunze@arm.com>2024-01-10 00:23:43 +0000
commit89ff71dbab705cd64a7c84892ad5569ab1e18a9a (patch)
tree4359031df6fa86bf70c3a1da956623128476a19d /CMakeLists.txt
parenta3961d01940120c15dceb7d7375677138ebd26bc (diff)
downloadreference_model-89ff71dbab705cd64a7c84892ad5569ab1e18a9a.tar.gz
CMake update to quiet warnings
Update the minimum cmake version to 3.16 and set policy CMP0135 Signed-off-by: Eric Kunze <eric.kunze@arm.com> Change-Id: Idd96c7a318f9458e39d38cd07cf29b9ac6ee63ad
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 117bc9f..c4e7bf8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,18 @@
-cmake_minimum_required (VERSION 3.4)
+cmake_minimum_required (VERSION 3.16)
+
+# Copyright (c) 2023-2024, ARM Limited.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
set(CMAKE_INSTALL_PREFIX ".")
project(tosa_tools LANGUAGES CXX)