aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorRaul Farkas <raul.farkas@arm.com>2022-10-12 10:48:35 +0100
committerRaul Farkas <raul.farkas@arm.com>2022-10-18 14:29:23 +0100
commit4fa21325ec498adbf467876c2413c054d0e85c5b (patch)
tree892d68467bc6666e9daf74ab4d141810dcec1ac6 /pyproject.toml
parent89c1f4bafb51dbbed705b6960810d90825318b13 (diff)
downloadmlia-4fa21325ec498adbf467876c2413c054d0e85c5b.tar.gz
MLIA-409 Create new Cortex-A device skeleton
* Add Cortex-A device skeleton * Add unit tests for the Cortex-A device skeleton * Update profiles.json by adding the new "cortex-a" profile * Add new cortex-a factory to the get_advisor method in api.py * Disable performance and optimization commands for the cortex-a profile. * Update trademarks section in README.md * Update pyproject.toml to not run similarity check in imports Change-Id: I2e228aaada1e2d3c5cc329d70572b51962ff517f
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 1dcbf21..52b7f41 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -43,6 +43,9 @@ enable = [
"line-too-long" # C0301
]
+[tool.pylint.similarities]
+ignore-imports = true
+
[tool.mypy]
# Suppresses error messages about imports that cannot be resolved
ignore_missing_imports = true