aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorBenjamin Klimczak <benjamin.klimczak@arm.com>2023-11-15 12:58:02 +0000
committerBenjamin Klimczak <benjamin.klimczak@arm.com>2023-11-15 13:02:36 +0000
commit2bd5b870c13d2785a3ff7177647f307e9ff3e58a (patch)
tree1d258c50df48c10b002a9eba8bc4a025bf58fb56 /pyproject.toml
parent2dd8f2e64e4ecfbd49ef05d9f6d2644dd11a0462 (diff)
downloadmlia-2bd5b870c13d2785a3ff7177647f307e9ff3e58a.tar.gz
Add linters/checkers for TOML files to pre-commits
Change-Id: I8a228cbab405b4d4112e5e38856b3cb92304cba7 Signed-off-by: Benjamin Klimczak <benjamin.klimczak@arm.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml21
1 files changed, 9 insertions, 12 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 52b7f41..827ae30 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -3,7 +3,6 @@
# SPDX-FileCopyrightText: Copyright (c) 2015-2022 Dropbox, Inc.
# SPDX-License-Identifier: Apache-2.0 AND MIT
-
[build-system]
requires = [
"setuptools>=42",
@@ -18,9 +17,9 @@ build-backend = "setuptools.build_meta"
[tool.pytest.ini_options]
testpaths = "tests"
markers = [
- "e2e", # e2e tests
- "install", # installation tests
- "command", # command tests
+ "e2e", # e2e tests
+ "install", # installation tests
+ "command", # command tests
"model_gen" # model generation tests
]
junit_logging = "all"
@@ -30,17 +29,15 @@ min-similarity-lines = 10
min-public-methods = 1
max-line-length = 88
max-args = 8
-max-attributes=10
-
+max-attributes = 10
# Provide basic compatibility with black
disable = [
- "wrong-import-order"
+ "wrong-import-order"
]
-
enable = [
- "dangerous-default-value", # W0102
- # black will reflow code lines, but won't touch comments, error on those
- "line-too-long" # C0301
+ "dangerous-default-value", # W0102
+ # black will reflow code lines, but won't touch comments, error on those
+ "line-too-long" # C0301
]
[tool.pylint.similarities]
@@ -73,6 +70,6 @@ check_untyped_defs = true
[[tool.mypy.overrides]]
module = [
"pkg_resources",
- "requests",
+ "requests"
]
ignore_missing_imports = true