summaryrefslogtreecommitdiff
path: root/source/profiler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/profiler/CMakeLists.txt')
-rw-r--r--source/profiler/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/source/profiler/CMakeLists.txt b/source/profiler/CMakeLists.txt
index e59dc01..b02b276 100644
--- a/source/profiler/CMakeLists.txt
+++ b/source/profiler/CMakeLists.txt
@@ -31,6 +31,11 @@ target_sources(profiler
target_include_directories(profiler PUBLIC include)
+# Set the CPU profiling defintiion
+if (CPU_PROFILE_ENABLED)
+ target_compile_definitions(profiler PRIVATE CPU_PROFILE_ENABLED)
+endif()
+
# Profiling API depends on the logging interface and the HAL library.
target_link_libraries(profiler PRIVATE log hal)