summaryrefslogtreecommitdiff
path: root/source/hal/source/components/npu_ta/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/hal/source/components/npu_ta/CMakeLists.txt')
-rw-r--r--source/hal/source/components/npu_ta/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/source/hal/source/components/npu_ta/CMakeLists.txt b/source/hal/source/components/npu_ta/CMakeLists.txt
index 6f7dac5..73bbef7 100644
--- a/source/hal/source/components/npu_ta/CMakeLists.txt
+++ b/source/hal/source/components/npu_ta/CMakeLists.txt
@@ -36,6 +36,10 @@ if (NOT DEFINED SOURCE_GEN_DIR)
set(SOURCE_GEN_DIR ${CMAKE_BINARY_DIR}/generated/ta)
endif()
+# Base address definitions for the two timing adapters (platform should override these):
+set(TA0_BASE "0x58103000" CACHE STRING "Ethos-U NPU timing adapter 0")
+set(TA1_BASE "0x58103200" CACHE STRING "Ethos-U NPU timing adapter 1")
+
## If a TA config file is provided, we generate a settings file
if (DEFINED TA_CONFIG_FILE)
include(${TA_CONFIG_FILE})