summaryrefslogtreecommitdiff
path: root/source/hal/source/components/npu_ta/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/hal/source/components/npu_ta/CMakeLists.txt')
-rw-r--r--source/hal/source/components/npu_ta/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/source/hal/source/components/npu_ta/CMakeLists.txt b/source/hal/source/components/npu_ta/CMakeLists.txt
index fdda723..6f7dac5 100644
--- a/source/hal/source/components/npu_ta/CMakeLists.txt
+++ b/source/hal/source/components/npu_ta/CMakeLists.txt
@@ -31,6 +31,11 @@ project(${ETHOS_U_NPU_TA_COMPONENT}
LANGUAGES C CXX ASM)
# Checks
+## Source generated Source path check
+if (NOT DEFINED SOURCE_GEN_DIR)
+ set(SOURCE_GEN_DIR ${CMAKE_BINARY_DIR}/generated/ta)
+endif()
+
## If a TA config file is provided, we generate a settings file
if (DEFINED TA_CONFIG_FILE)
include(${TA_CONFIG_FILE})