summaryrefslogtreecommitdiff
path: root/source/hal/source/components/lcd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/hal/source/components/lcd/CMakeLists.txt')
-rw-r--r--source/hal/source/components/lcd/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/source/hal/source/components/lcd/CMakeLists.txt b/source/hal/source/components/lcd/CMakeLists.txt
index 7378713..d260091 100644
--- a/source/hal/source/components/lcd/CMakeLists.txt
+++ b/source/hal/source/components/lcd/CMakeLists.txt
@@ -52,6 +52,14 @@ target_compile_definitions(${LCD_MPS3_COMPONENT_TARGET}
PRIVATE
CLCD_CONFIG_BASE=${CLCD_CONFIG_BASE})
+## Logging utilities:
+if (NOT TARGET log)
+ if (NOT DEFINED LOG_PROJECT_DIR)
+ message(FATAL_ERROR "LOG_PROJECT_DIR needs to be defined.")
+ endif()
+ add_subdirectory(${LOG_PROJECT_DIR} ${CMAKE_BINARY_DIR}/log)
+endif()
+
## Add dependencies
target_link_libraries(${LCD_MPS3_COMPONENT_TARGET} PUBLIC
${LCD_IFACE_TARGET}