summaryrefslogtreecommitdiff
path: root/source/hal/cmsis_device/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/hal/cmsis_device/CMakeLists.txt')
-rw-r--r--source/hal/cmsis_device/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/source/hal/cmsis_device/CMakeLists.txt b/source/hal/cmsis_device/CMakeLists.txt
index 255bd30..b98feb2 100644
--- a/source/hal/cmsis_device/CMakeLists.txt
+++ b/source/hal/cmsis_device/CMakeLists.txt
@@ -56,13 +56,18 @@ target_sources(${CMSIS_DEVICE_TARGET}
# Device definition needs to be set, is checked in source files to include correct header
target_compile_definitions(${CMSIS_DEVICE_TARGET} PUBLIC ${ARM_CPU})
-
# Tell linker that reset interrupt handler is our entry point
target_link_options(
${CMSIS_DEVICE_TARGET}
INTERFACE
--entry Reset_Handler)
+# Check if semihosting configuration is available
+if (COMMAND configure_semihosting)
+ option(USE_SEMIHOSTING "Enable/disable semihosting option" OFF)
+ configure_semihosting(${CMSIS_DEVICE_TARGET} ${USE_SEMIHOSTING})
+endif()
+
# 4 Display status:
message(STATUS "CMAKE_CURRENT_SOURCE_DIR: " ${CMAKE_CURRENT_SOURCE_DIR})
message(STATUS "*******************************************************")