summaryrefslogtreecommitdiff
path: root/scripts/cmake/cmsis-pack-gen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/cmake/cmsis-pack-gen/CMakeLists.txt')
-rw-r--r--scripts/cmake/cmsis-pack-gen/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/scripts/cmake/cmsis-pack-gen/CMakeLists.txt b/scripts/cmake/cmsis-pack-gen/CMakeLists.txt
index 2a25aec..2774ab2 100644
--- a/scripts/cmake/cmsis-pack-gen/CMakeLists.txt
+++ b/scripts/cmake/cmsis-pack-gen/CMakeLists.txt
@@ -51,3 +51,12 @@ file(GLOB UC_API_LIST "${API_UC_PROJECT_DIR}/*")
foreach(API ${UC_API_LIST})
add_subdirectory(${API} ${CMAKE_BINARY_DIR}/${API})
endforeach()
+
+# Any custom steps that are required for the CMSIS pack generation flow
+# must be declared here:
+if (CMSIS_PACK_GEN_FLOW)
+ # For CMSIS packs, we need CMSIS DSP definition.
+ # @TODO: Currently, this line is added multiple times to the include file. Uncomment when
+ # packgen is fixed.
+ # add_compile_definitions(arm_math PRIVATE ARM_MATH_DSP)
+endif()