summaryrefslogtreecommitdiff
path: root/source/hal/source/platform/mps3/CMakeLists.txt
diff options
context:
space:
mode:
authorRichard Burton <richard.burton@arm.com>2023-12-06 17:13:10 +0000
committeralex.tawse <alex.tawse@arm.com>2024-01-23 17:26:45 +0000
commitcefc7e1cacdd3028b46325b3a1f6c15416914b2f (patch)
treed0353f7775d18a207d8a9fd352a3b716ea7b9773 /source/hal/source/platform/mps3/CMakeLists.txt
parent001a8ff315dc766a206b05a3e00e831e3f972b0d (diff)
downloadml-embedded-evaluation-kit-cefc7e1cacdd3028b46325b3a1f6c15416914b2f.tar.gz
MLECO-4503: Adding video VSI for object detectionexperimental/vsi
* Added Board support - Arm Corstone 300 and 310 * Added Python Scripts for Video VSI * Added source files for Video VSI * Add new usecase handler for OD use case * Bumped resampy version to resolve issue with slowdown Signed-off-by: Idriss Chaouch <idriss.chaouch@arm.com> Signed-off-by: Richard Burton <richard.burton@arm.com> Change-Id: Ie59ae955d4d85f672a49c63733052624542aec85
Diffstat (limited to 'source/hal/source/platform/mps3/CMakeLists.txt')
-rw-r--r--source/hal/source/platform/mps3/CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/source/hal/source/platform/mps3/CMakeLists.txt b/source/hal/source/platform/mps3/CMakeLists.txt
index 5008f0b..2791150 100644
--- a/source/hal/source/platform/mps3/CMakeLists.txt
+++ b/source/hal/source/platform/mps3/CMakeLists.txt
@@ -1,5 +1,5 @@
#----------------------------------------------------------------------------
-# SPDX-FileCopyrightText: Copyright 2022 Arm Limited and/or its affiliates <open-source-office@arm.com>
+# SPDX-FileCopyrightText: Copyright 2022, 2024 Arm Limited and/or its affiliates <open-source-office@arm.com>
# SPDX-License-Identifier: Apache-2.0
#
# Licensed under the Apache License, Version 2.0 (the "License");
@@ -133,6 +133,18 @@ if (CPU_PROFILE_ENABLED)
target_compile_definitions(${PLATFORM_DRIVERS_TARGET} PUBLIC CPU_PROFILE_ENABLED)
endif()
+# If Virtual Streaming Interface is enabled, we need to link the vsi driver
+if (VSI_ENABLED)
+ target_sources(${PLATFORM_DRIVERS_TARGET}
+ PRIVATE
+ source/vsi_mps3.c)
+ add_subdirectory(${COMPONENTS_DIR}/vsi ${CMAKE_BINARY_DIR}/vsi)
+
+ target_link_libraries(${PLATFORM_DRIVERS_TARGET}
+ PUBLIC
+ arm_vsi)
+endif ()
+
# If Ethos-U is enabled, we need the driver library too
if (ETHOS_U_NPU_ENABLED)