summaryrefslogtreecommitdiff
path: root/source/hal/platform/simple/CMakeLists.txt
diff options
context:
space:
mode:
authorKshitij Sisodia <kshitij.sisodia@arm.com>2022-03-14 09:26:48 +0000
committerKshitij Sisodia <kshitij.sisodia@arm.com>2022-03-14 17:18:25 +0000
commitc22e80e25521bdd291fdef9ba20194ce9d2a8544 (patch)
treeb8ffe314220d4d04e84dbd6a240f77271c1e5e70 /source/hal/platform/simple/CMakeLists.txt
parent1716efd0b35889b580276e27c8b6f661c9858cd0 (diff)
downloadml-embedded-evaluation-kit-c22e80e25521bdd291fdef9ba20194ce9d2a8544.tar.gz
MLECO-2919: Restructuring to standardise HAL APIs
* LCD module component created (removed from individual platform packs). * retarget.c moved out into its own component that wraps the uart module. It also have the native stub for GetLine => paved the way for removing data_acq module from profiles. * shortened names for components' dir for npu and ta * remove peripheral_memmap and peripheral_irqs headers from platform_drivers.h. There should be no need for these to be included in the top level now. These should be private headers. * cmsis_device moved in as a component. * Pyenv created by set_up_default_resource.py will also install packages that CMake's source generator needs. TODO's: * Remove timer from profiles (MLECO-3096) Change-Id: I9d6ea2f4f291788f40a16ed507019563c8d7f205
Diffstat (limited to 'source/hal/platform/simple/CMakeLists.txt')
-rw-r--r--source/hal/platform/simple/CMakeLists.txt123
1 files changed, 0 insertions, 123 deletions
diff --git a/source/hal/platform/simple/CMakeLists.txt b/source/hal/platform/simple/CMakeLists.txt
deleted file mode 100644
index df4df00..0000000
--- a/source/hal/platform/simple/CMakeLists.txt
+++ /dev/null
@@ -1,123 +0,0 @@
-#----------------------------------------------------------------------------
-# Copyright (c) 2022 Arm Limited. All rights reserved.
-# SPDX-License-Identifier: Apache-2.0
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#----------------------------------------------------------------------------
-
-#########################################################
-# A generic (simple) platform support library #
-#########################################################
-
-cmake_minimum_required(VERSION 3.15.6)
-set(PLATFORM_DRIVERS_TARGET platform_drivers)
-project(${PLATFORM_DRIVERS_TARGET}
- DESCRIPTION "Platform drivers library for a generic target"
- LANGUAGES C CXX ASM)
-
-# 1. We should be cross-compiling (MPS3 taregt only runs Cortex-M targets)
-if (NOT ${CMAKE_CROSSCOMPILING})
- message(FATAL_ERROR "No ${PLATFORM_DRIVERS_TARGET} support for this target.")
-endif()
-
-# 2. Set the platform cmake descriptor file
-if (NOT DEFINED PLATFORM_CMAKE_DESCRIPTOR_FILE)
- set(PLATFORM_CMAKE_DESCRIPTOR_FILE
- ${CMAKE_CURRENT_SOURCE_DIR}/cmake/subsystem-profiles/simple_platform.cmake)
-endif()
-
-## Include the platform cmake descriptor file
-include(${PLATFORM_CMAKE_DESCRIPTOR_FILE})
-
-# 3. Generate sources:
-if (NOT DEFINED SOURCE_GEN_DIR)
- set(SOURCE_GEN_DIR ${CMAKE_BINARY_DIR}/generated/bsp)
-endif()
-
-set(MEM_PROFILE_TEMPLATE ${CMAKE_CURRENT_SOURCE_DIR}/cmake/templates/peripheral_memmap.h.template)
-set(IRQ_PROFILE_TEMPLATE ${CMAKE_CURRENT_SOURCE_DIR}/cmake/templates/peripheral_irqs.h.template)
-set(MEM_REGIONS_TEMPLATE ${CMAKE_CURRENT_SOURCE_DIR}/cmake/templates/mem_regions.h.template)
-
-configure_file("${MEM_PROFILE_TEMPLATE}" "${SOURCE_GEN_DIR}/peripheral_memmap.h")
-configure_file("${IRQ_PROFILE_TEMPLATE}" "${SOURCE_GEN_DIR}/peripheral_irqs.h")
-configure_file("${MEM_REGIONS_TEMPLATE}" "${SOURCE_GEN_DIR}/mem_regions.h")
-
-# 4. Create static library
-add_library(${PLATFORM_DRIVERS_TARGET} STATIC)
-
-## Include directories - public
-target_include_directories(${PLATFORM_DRIVERS_TARGET}
- PUBLIC
- include
- ${SOURCE_GEN_DIR})
-
-## Platform sources
-target_sources(${PLATFORM_DRIVERS_TARGET}
- PRIVATE
- source/stubs_glcd.c
- source/timer_simple_platform.c
- source/platform_drivers.c)
-
-## Directory for additional components required by generic platform:
-if (NOT DEFINED COMPONENTS_DIR)
- set(COMPONENTS_DIR ${CMAKE_CURRENT_SOURCE_DIR}/../../components)
-endif()
-
-## Platform component: uart
-add_subdirectory(${DEPENDENCY_ROOT_DIR}/core-platform/drivers/uart ${CMAKE_BINARY_DIR}/uart)
-
-## Compile defs
-target_compile_definitions(${PLATFORM_DRIVERS_TARGET}
- PUBLIC
- ACTIVATION_BUF_SRAM_SZ=${ACTIVATION_BUF_SRAM_SZ})
-
-# Add dependencies:
-target_link_libraries(${PLATFORM_DRIVERS_TARGET} PUBLIC
- cmsis_device
- log
- ethosu_uart_pl011)
-
-# If Ethos-U is enabled, we need the driver library too
-if (ETHOS_U_NPU_ENABLED)
-
- target_compile_definitions(${PLATFORM_DRIVERS_TARGET}
- PUBLIC
- ARM_NPU)
-
- ## Platform component: Ethos-U initialization
- add_subdirectory(${COMPONENTS_DIR}/ethosu_npu_init ${CMAKE_BINARY_DIR}/ethosu_npu_init)
-
- target_link_libraries(${PLATFORM_DRIVERS_TARGET}
- PUBLIC
- ethosu_npu_init_component)
-
- if (ETHOS_U_NPU_TIMING_ADAPTER_ENABLED)
- ## Platform component: Ethos-U timing apadpter initialization
- add_subdirectory(${COMPONENTS_DIR}/ethosu_ta_init ${CMAKE_BINARY_DIR}/ethosu_ta_init)
-
- target_link_libraries(${PLATFORM_DRIVERS_TARGET}
- PUBLIC
- ethosu_ta_init_component)
- target_compile_definitions(${PLATFORM_DRIVERS_TARGET}
- PUBLIC
- ETHOS_U_NPU_TIMING_ADAPTER_ENABLED)
- endif()
-
-endif()
-
-# 5. Display status:
-message(STATUS "CMAKE_CURRENT_SOURCE_DIR: " ${CMAKE_CURRENT_SOURCE_DIR})
-message(STATUS "*******************************************************")
-message(STATUS "Library : " ${PLATFORM_DRIVERS_TARGET})
-message(STATUS "CMAKE_SYSTEM_PROCESSOR : " ${CMAKE_SYSTEM_PROCESSOR})
-message(STATUS "*******************************************************")