summaryrefslogtreecommitdiff
path: root/source/hal/platform/native/CMakeLists.txt
diff options
context:
space:
mode:
authorKshitij Sisodia <kshitij.sisodia@arm.com>2022-03-14 09:26:48 +0000
committerKshitij Sisodia <kshitij.sisodia@arm.com>2022-03-14 17:18:25 +0000
commitc22e80e25521bdd291fdef9ba20194ce9d2a8544 (patch)
treeb8ffe314220d4d04e84dbd6a240f77271c1e5e70 /source/hal/platform/native/CMakeLists.txt
parent1716efd0b35889b580276e27c8b6f661c9858cd0 (diff)
downloadml-embedded-evaluation-kit-c22e80e25521bdd291fdef9ba20194ce9d2a8544.tar.gz
MLECO-2919: Restructuring to standardise HAL APIs
* LCD module component created (removed from individual platform packs). * retarget.c moved out into its own component that wraps the uart module. It also have the native stub for GetLine => paved the way for removing data_acq module from profiles. * shortened names for components' dir for npu and ta * remove peripheral_memmap and peripheral_irqs headers from platform_drivers.h. There should be no need for these to be included in the top level now. These should be private headers. * cmsis_device moved in as a component. * Pyenv created by set_up_default_resource.py will also install packages that CMake's source generator needs. TODO's: * Remove timer from profiles (MLECO-3096) Change-Id: I9d6ea2f4f291788f40a16ed507019563c8d7f205
Diffstat (limited to 'source/hal/platform/native/CMakeLists.txt')
-rw-r--r--source/hal/platform/native/CMakeLists.txt56
1 files changed, 0 insertions, 56 deletions
diff --git a/source/hal/platform/native/CMakeLists.txt b/source/hal/platform/native/CMakeLists.txt
deleted file mode 100644
index 0b9fee1..0000000
--- a/source/hal/platform/native/CMakeLists.txt
+++ /dev/null
@@ -1,56 +0,0 @@
-#----------------------------------------------------------------------------
-# Copyright (c) 2022 Arm Limited. All rights reserved.
-# SPDX-License-Identifier: Apache-2.0
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#----------------------------------------------------------------------------
-
-#########################################################
-# Native target platform support library #
-#########################################################
-
-cmake_minimum_required(VERSION 3.15.6)
-
-set(PLATFORM_DRIVERS_TARGET platform_drivers)
-
-project(${PLATFORM_DRIVERS_TARGET}
- DESCRIPTION "Platform drivers library for native target"
- LANGUAGES C CXX)
-
-# We should not be cross-compiling
-if (${CMAKE_CROSSCOMPILING})
- message(FATAL_ERROR "Native drivers not available when cross-compiling.")
-endif()
-
-
-# Create static library
-add_library(${PLATFORM_DRIVERS_TARGET} STATIC)
-
-## Include directories - public
-target_include_directories(${PLATFORM_DRIVERS_TARGET}
- PUBLIC
- include)
-
-## Platform sources
-target_sources(${PLATFORM_DRIVERS_TARGET}
- PRIVATE
- source/platform_drivers.c)
-
-# Add dependencies:
-target_link_libraries(${PLATFORM_DRIVERS_TARGET} PUBLIC log)
-
-# Display status:
-message(STATUS "*******************************************************")
-message(STATUS "Library : " ${PLATFORM_DRIVERS_TARGET})
-message(STATUS "CMAKE_SYSTEM_PROCESSOR : " ${CMAKE_SYSTEM_PROCESSOR})
-message(STATUS "*******************************************************")